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LICENSE: Web Error Code 9939 or Licensing Error Codes L9555E, R203(8)


Information in this knowledgebase article applies to:


SYMPTOM

When following these steps for license registration, the Keil webpage gives the following error message:

Problems were detected with the information submitted. Please correct these issues and re-submit the form.

  • A problem was encountered with your Serial Number. Please contact Technical Support and report code 9939 for assistance with your installation. They will work quickly to help you obtain the proper license code for your product.

Or, another symptom: when compiling, the Build Output window may list one of these errors:

  • LICENSE ERROR (R203(8): EVALUATION PERIOD EXPIRED)
    
  • Error L9555E: License checkout for feature
      LIC0=3A...-.....-..... with version 5.0201601 has been denied by
      Keil back-end. Error code: 1
    

    (Alternative licensing error codes could be A9555E, C9555E, or Q9555E)

CAUSE

This error comes up if during the registration, you enter a Product Serial Number (PSN) that already has expired.

RESOLUTION

For Silicon Labs users:

The Master PSN for Silicon Labs changed. Contact Silicon Labs and make sure you have the latest Master PSN. Other workarounds for a 9939 issue:

For Other Users

MORE INFORMATION

SEE ALSO

Last Reviewed: Thursday, December 10, 2020


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