Keil Logo

ULINK: STARTUP PROBLEMS WITH INFINEON OCDS ON XC16X


Information in this article applies to:

  • ULINK USB-JTAG Adapter
  • ULINK2 USB-JTAG Adapter

QUESTION

We have a problem with OCDS debugging on a new board using XC167. The board is very simple, we are setting the XC167 in single-chip mode with /EA==1 (no pull down). When I try to connect with OCDS, µVision replies that it cannot detect the hardware and displays a message box:

Error: Target DLL has been cancelled.
Debugger aborted!

If the board is not powered, or in bootstrap mode (using the /RD pull down), µVision shows the correct error message.

Do you have any idea on the mistake?

ANSWER

There are a couple of potential issues that need to be taken care of when using OCDS. Check the following:

  1. XTAL frequency: we have seen that XTAL is a critical point. Use for starting an 8MHz XTAL as on the Infineon board.
  2. RESET logic: sometimes an off-chip reset logic causes problems. You should remove a capacitor on the reset input for testing.
  3. +5V power supply:The OCDS pin 2 (VCC) should be connected to +5V. ULINK has an internal jumper that should be in EXT position so that the drivers are using 5V. We have seen that 3.3V (which is the internal ULINK voltage) sometimes creates problems with external logic.

MORE INFORMATION

SEE ALSO

ULINK: XC16X OCDS INTERFACE DOES NOT WORK

FORUM THREADS

The following Discussion Forum threads may provide information related to this topic.

Last Reviewed: Sunday, January 28, 2007


Did this article provide the answer you needed?
 
Yes
No
Not Sure
 
  Arm logo
Important information

This site uses cookies to store information on your computer. By continuing to use our site, you consent to our cookies.

Change Settings

Privacy Policy Update

Arm’s Privacy Policy has been updated. By continuing to use our site, you consent to Arm’s Privacy Policy. Please review our Privacy Policy to learn more about our collection, use and transfers
of your data.