Keil Logo

LICENSE: Reach FlexLM Server over DirectAccess


Information in this knowledgebase article applies to:

  • Keil MDK

SYMPTOM

I connect to our company network with DirectAccess (VPN-like technology from Microsoft that provides intranet connectivity to client computers). This works fine. However, when trying to use the Keil MDK license from our internal FlexLM server, the tools generate Flex error code: -15, as the server can't be reached. Why does this not work? The server name in the FlexLM settings is correct.

CAUSE

To contact the server, the client first needs to resolve the server name to an IP address. By default, IPv4 name resolution is used. However, DirectAccess uses only IPv6 to reach the company intranet. So, the FlexLM Server can't be reached via the IPv4 address.

RESOLUTION

The FlexLM client can use the environment variable FNP_IP_PRIORITY to prioritize the used IP version for the name resolution. Set:

FNP_IP_PRIORITY=6

on the client to let it use IPv6 first. This causes the client to connect the server with its IPv6 address, and the license should work.

MORE INFORMATION

SEE ALSO

Last Reviewed: Thursday, November 12, 2020


Did this article provide the answer you needed?
 
Yes
No
Not Sure
 
  Arm logo
Important information

This site uses cookies to store information on your computer. By continuing to use our site, you consent to our cookies.

Change Settings

Privacy Policy Update

Arm’s Privacy Policy has been updated. By continuing to use our site, you consent to Arm’s Privacy Policy. Please review our Privacy Policy to learn more about our collection, use and transfers
of your data.