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Chapter 1
Introduction

The S32 Software Development Kit (S32 SDK) is an extensive suite of robust hardware
interface and hardware abstraction layers, peripheral drivers, RTOS, stacks and
middleware designed to simplify and accelerate application development on NXP S32K
microcontrollers.

This manual explains how to use the S32 SDK product, including the use with S32 Design
Studio, for easier application creation and configuration with graphical user interface.

1.1 System requirements

Hardware * 1.8 GHz processor
» 2 GB of RAM

Operating System Microsoft® Windows® 7.

Gnu Make For usage without S32 Design Studio.

Supported Compiler For usage without S32 Design Studio. See release
notes for supported versions.

Disk Space Approximately 150 MB of free disk space (when
installing standalone)

NOTE
The S32 Design Studio software development tools requirements
are covered by their own Quick Start Guide. PEx graphical
configuration tool can only be used with S32 Design Studio.

1.2 Installing S32 SDK

1.2.1 Bundled in S32 Design Studio

S32 SDK is delivered bundled in the S32 Design Studio. In this case it’s already configured
and ready to use.

1.2.2 Standalone

S32 SDK is also delivered through a standalone installer. Using the standalone installer is
recommended when using a compiler which is not supported in S32 Design Studio or
S32 SDK Quick Start Guide, Rev. 1.3, 03/2017
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when the graphical interface is not required. In this case the installer can configure an
existing S32 Design Studio to use the configuration files delivered in the installer.

If the integration with the S32 Design Studio is not needed the path to S32 Design Studio
can be left empty — and in this case, only the S32 SDK will be installed and configured.

1.3 Release Notes

Before using the S32 SDK, read the release notes. These notes contain important
information about last-minute changes, bug fixes, incompatible elements, or other topics
that may not be included in this manual. The product comes with the release notes
installed.

1.4 Terminology

The following are some of the terms used in the document.
Table 1-1. Terminology

Term Description

S32 SDK Software development kit that provides comprehensive software support for
NXP S32 devices. The S32 SDK includes a Hardware Abstraction Layer (HAL)
for each peripheral and peripheral drivers built on top of the HAL. S32 SDK
also contains the latest available RTOS kernels, a LIN stack and SBC
middleware to support rapid development on supported S32K devices.

Processor Expert Rapid application design tool targeted for NXP microcontrollers providing the
following key features:
* A Graphical User Interface which allows an application to be specified by
the functionality needed.
» An application created from Embedded Components encapsulating
initialization and functionality of basic elements of embedded systems.
* An automatic code generator which creates tested and optimized C code
which is tuned to your application needs and the selected NXP device.
* A built-in knowledge base, which immediately flags resource conflicts and
incorrect settings, so errors are caught early in design cycle allowing you
to get to market faster with a higher quality product.
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Chapter 2
Working with Projects

This chapter explains how to use the S32 Design Studio to create and work with S32
SDK projects.

A project organizes files and various compiler, linker, and debugger settings associated
with the applications or libraries you develop. S32 New Project wizard can be used to
create projects that group these files and settings into build and launch configurations.

2.1 Creating and building S32DS project

The New S32DS Project wizard help you to quickly create new projects. The wizard
generates a project with placeholder files and default settings (build and launch
configurations) for specified target. After the project has been created, you can easily
change any default setting to suit your needs.

To create a S32 SDK project using the New S32DS Project wizard:
1. Launch the S32 Design Studio. Please refer to S32 Design Studio documentation.

2. Select File > New > New S32DS Project, from the IDE menu bar.
The New S32DS Project page of the New S32DS Project wizard appears.

| New 53205 Project E=EE~=

New 532DS Project
Create New 532D5 Project

Project name:  projectl

Use default location
C:\Oficial2y532_ARM_v1.2_31Mar\eclipse\workspace532D5.ARM\projectl Browse...

EIf $32D5 project | Library project

Project Type: ToelChain Selection:
Processor Core Kind MName ToolChain
4 (= Family $32K1xx M4 Cortex-M4F Standard 5322D5 toolchain for ARM =
B S32K144
> (= Family MAC57D 5xx Description :
> (= Family 532V GCC toolchain is selected 0
> (= Family KEA

':?;' < Back Mext = Finish

Figure 1 New S32DS Project page
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3. Specify a name for the new project. For example, enter the project name as s,oject1-

4. Select S32K144 Processor from EIf S32DS project tab

5. Click Next, The New S32DS Project for S32K144 page of the New S32DS Project
wizard appears

| New $32DS Project B X

MNew 532DS Project for 532K144

Select required cores and parameters for them.

Project Mame projectl

Core Cortex-MAF

Library EWL =
/0 Support No I/O N
FPU Support Toolchain Default N
Language C -
sDks L)
Debugger PE Micro GDB server ~

@ Med> | Finish || Cancel

—

Figure 2 New S32DS Project for S32K144 page

6. Click on L= button to select from available SDKs, The Select SDK page of the
New S32DS Project wizard appears

Mame Version Description Status Add...

[ S32K14x AMMCLIE_... 116 Automotive Math and Motor Control Library Set for 5. Contributed SDK
[] FreeMaster_532xx 200 FreeMASTER Serial Communication Driver for 532 Contributed SDK

Edit/Show info...

[7] 532K144_SDK_gce 082 532K144 EAR SDK for GCC Contributed SDK Remove
[7] 532K144_SDK_gce 080 532K144 Beta SDK for GCC Contributed SDK
[ 532K144_5DK_gec 100 532K144 Beta RTM for GCC Contributed SDK

Clone from git

Figure 3 Select SDK page
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7. Select the latest version of S32K144 SDK, and then click OK.

8. Review the settings and click Finish, project should be created and default view
should be presented.

Source Refactor Mavigate Search Project Run Processor Expert Window Help

Eile Edit

i S ®- K- [ @ (O]9 Q- LURLAE: N=R = AR CRER SR Quick Access | [ | [AF C/Ce+ ]
[ Project Explorer 53 B&|lse =0 £y Component Inspector - pin_mux 52 5 Components Librs Advan:ed B v=p0 Fox s y T =8
4|5 projectl: Debu, Lo =N -
Py 9 Routing “._ Functicnal Properties | Methods | Settings ¢ B w X @ *
- allLInclude U Cpuh
View Mode Options Gener B pin_muxh
= Proy tartup_Cod @ Collapsed () Pins  [] Show Only Configurable Signals HTh U clockManl.h
(2 SDK. @ " exit_code : volatile int
b [ Sources . d):int
&8 nclude ADC| CAN| CMP| EWM|"FLEXIO  FTM| GPIO| JTAG|®LPLC ™ LPSPI| " LPTMR|™ LPUART = Platform meinoid < in
> (2 Documentation Signals Pin/Signal Selection Direction Selected Pin/Signal !
i (= Project_Settings
R Processorbxpert.pe 4 ADCO
Channel 0 PTAQ Input PTAD
Channel 1 PTAZ Input PTA1
Channel 2 PTAG Input PTAG
Channel 3 PTA7 Input PTAT
Channel 4 PTEQ Input PTED
Channel 5 PTB1 Input PTB1
Channel & PTBZ Input PTB2
Channel 7 BTR2 Tnnut DTR2
< i ] »
[€ main.c 2 = 0
oy -
_ - Filename : main.c E
&5 Components - project] &% B R H
» (= Generator_Configurations opli J
> = 0Ss tt
4 [= Processors Contents :
b .3 Cpu:532K144_100 Mo public methods
4 (= Components .
» U pin_muxPinSettings &+l
» 3 clockManl:clock_manager ‘s @File main.c
> 0] intManLinterrupt_manager ** fsarcinn a1 ad
[
t Problems &3 Console ¢ ¥ = 0
0 items
Description Resource Path Location Type

5 projectl

Figure 4 Default view after project creation

9. Processor Expert components can be observed the Components View, to add new
components open Component Library. (which can be opened from toolbar menu
Windows -> Show View)

10.Generate the driver configuration by clicking on # (or using toolbar menu Project
-> Generate Processor Expert Code). The generated configuration will be placed in
Generated_Code folder in project.
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11. Start project build by clicking on |, or invoking right click menu on project and
selecting Build Project.

2.2 Importing an existing project

This section explains how to import an existing S32 Design Studio SDK project in S32
Design Studio.

To import an existing project:
1. Select File > Import, from the IDE menu. Choose import source page will appear.

File | Edit Source Refactor Navigate Search Pr
New Alt+Shift+N »
Open File...

Close Ctrl+W

Close All Ctrl+Shift+ W

Save Ctrl+S
Save As..,

Save All Ctrl+Shift+S
Revert

Move...
Rename... F2
2| Refresh F5

Convert Line Delimiters To »
Print... Ctrl+P

Switch Workspace »
Restart

Import...
Export...

L&

Properties Alt+Enter

Exit

Figure 5 Select import option
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2. Expand General tree and Select Existing Projects into Workspace

% Import Lo [
Select \
Create new projects from an archive file or directory. | -E_ - 5 I

Select an import source:

type filter text

4 (= General
G, Archive File F
& Existing Projects into Workspace
[, File System
=), Preferences

b & C/C++

b (&= Component Development Environment

b = CVS

b = Git

b (= Install

b (& Processor Expert

> [ Project of Projects

b (= Remote Systems

> = RPM

r 23 Run/Nehun %

>

m

@ T e |

Figure 6 Choose import source

Figure 2-10. Select an import source
3. Click Next. The Import projects screen appears.

4. Click Browse and select the example folder from SDK installation directory to
search for an existing Eclipse project.
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NOTE
When using the S32 SDK bundled inside S32 Design Studio the
example folder is located in <S32 Design Studio install>
\S32DS\S32_ SDK_RTM_1.0.0\examples

5. Select the project you want to import in your Workspace (It is useful that Copy to
Workspace is selected in this window. In this way the original project will be
preserved).

6. Click Finish. The imported project will appear in the Project Explorer view. Similar
to Default view after project creation.

2.3 Using New Project From Example

S32 Design Studio provides support for accessing the examples from the S32 SDK using
the New Project from Example. To use this feature follow the next steps:

1. Select File -> New -> New S32DS Project From Example. The following
window will appear.

Import example project

Project
> [ 532D5 Example Projects
> [ 532D5 Example Projects
> = 532K144 Beta SDK +0.9.0 Example Projects

4 (= 532K144 RTM SDK v1.0.0 Example Projects

4 (= demo_apps
L= adc_low power

= ammclib

= flexcan_encrypted

= freemaster

= freertos

= helle_world

= lin_master

= lin_slave

4 [= driver_sxamples
4 (= analog
= adc_hwtrigger
= adc_swtrigger
= cmp dac
MName

adc_low_power

Description

This demo application shows how to use alternative hardware triggering for ADC via -
TRGMUX, LPUART with DMA and Power Manager.
The example documentation can be found in the 532 SDK documentation at Examples ant =

@ [ Finish ] [ Cancel ]

Figure 7 New Project from Example
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2. Select the desired project from the release version and click on Finish. The project
will be copied in your workspace.

2.4 Using a Makefile Project

To build a Makefile project without S32 Design Studio the system needs to have a make
utility (GNU version 3.0 and above, or equivalent) and a supported compiler. Please
refer to S32 SDK Release Notes for a list of supported compilers and their supported
version. Example projects are delivered for all supported compilers.

The makefile projects assumes that the make utility and corresponding compiler are
included in path.

1.
2.

Open a command line window (Start->Run->cmd.exe)
Navigate to project folder - makefile project are locate in example folder.

NOTE
Please check Release Notes or S32 SDK documentation for list
of available makefile projects

Execute make all command. This, depending on the used makefile, will generate one
or more elf files.

NOTE
For not relying on System PATH variable the user can temporary

modify the PATH variable as follows:
set PATH=%PATH%;<path to make>;<path to compiler>

The elf files can be deployed using one of the supported debugger. Please refer to
debugger documentation for flashing and debugging the application.

S32 SDK Quick Start Guide, Rev. 1.3, 03/2017
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Example:

Sinrod exanplessS532Kid4sdemo_appssblinking_LEDGCC—MKF

Sisexampless532Ki44~demo_appsshlinking_ LEDS~GCC—MKF*make all

Checked for uname.

found: MINGW3I2_NT-6.1

Azsuming Unix like environment

Compiling

Compiling

Build completet?

SovexamplessS532Kli44 v demo_appsshblinking_LEDSNGCC-MHEF >dir
Uolume in drive 5 iz Primary
Uolume Serial Humber is BCP4-DCFE

Directory of S:-“examplessS532Kid4d~demo_appssblinking_LEDSGCC—MKF

A2-8%.-2017
Az-a%-2017
az-a%-2817?7
Az-a8%.-2017
az-a%-2817?7
Az2-8%.-2017
az-a7-28a17?
Az-a87.-2017
az-a%2-28a17?7

A4:58
A4:58
A4:58
A4:5@
A4:58
A4:5@
A5:12
As:12
a4:58

<DIR> -
<DIR> --
L6854
22.485 app_flash.map
L5.681
21.195 app_ram.map
4.14% HMakefile
3.747 Makefile-arm
<DIR> obj

6 Fileds> 163,311 hytes
3 Dir<s>» 282.046.857.216 bytes free

2.5 Debugging Projects

When you use the S32 Design Studio to create a new project, the wizard sets the
debugger settings of the project's launch configurations to default values. You can
change these default values based on your requirements.

To debug a project, perform these steps.

1. Launch the IDE and have a project opened and selected.

S32 SDK Quick Start Guide, Rev. 1.3, 03/2017
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NOTE
Please ensure that the current perspective is C/C++ or Debug.
Current perspective is indicated usually in upper right corner in
eclipse window. Use Window -> Open Perspective to change
current eclipse perspective. Use Window-> Reset perspective to
reset all the Views to their default location and visibility.

2. Click * The Launch Configuration Selection dialog appears.
Alternatively, you can select Run > Debug Configurations from the IDE menu bar.
NOTE
The launch/debug configurations are populated with the default
settings; these might need to be adjusted to accommodate various
configuration. Please refer to S32 Design Studio documentation
for Launch configuration settings.

3. Select the launch configuration you want to debug.

i N

-7 | Select Configuration (=l 2

Select a configuration to launch:

fc] projectl_Release
[c]projectl_Debug_RAM
[c]projectl_Debug

=y .

L -

Figure 8 Select launch configuration
4. Click OK. The IDE uses the settings in the launch configuration to generate
debugging information and initiate communications with the target board.

S32 SDK Quick Start Guide, Rev. 1.3, 03/2017
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2.6 Graphical Configuration of Drivers

The simplest way to configure the driver is to use the Processor Expert configurator
available in S32 Design Studio. Alternatively, the configuration can be written manually
in a text editor.

Here are the steps requires to graphically configure a driver:

1.
2.

Launch the IDE

Open Components View (double click on ProcessorExpert.pe file from project or
from toolbar Window->Show View ->Components)

If the desired component is not in Components View, open Components Library
(Windows -> Show view) and double click on desired component

If the need component is in Components View, right click on it and select Inspector
from context menu.

C/C++ - project1/Sources/main.c - 532 Desig

File Edit Source Refactor MNavigate Search Project Run Processor Expert Window Help

A HRL D - A RE @ @G B 0B N|E S ®E P S TS G Quickceess | 53 | (ETERT)
[t Project Explorer 52 E&|%® Y= 0 £ Componentinspector - Ipuartl %y Components Library 2 B v=08 Sonr - T =8
4 5 projectl: Debu 4R w -
B 3 Alphabetical ._Categories| Pracessors | Board Configurations o RN e %
&l Includes = Cpuh
» G Generated Code ¥ [All repositories ~ | [Applicable to project ~ o pin_muxh
> 3 Project_Settings/Startup_Code 2 clockManl.h
b 5 SDK Component Component Repository Description & @Y eit_code: velatile int
b 2 Seurces [ lpspi_hal SDK_S22K144_032 532 SDK HAL for Low Power Serial Peripheral Interface | @ main(void) : int
@ include @) Iptmr SDK_532K144_03 532 SDK Peripheral Driver for Low Power Timer (Iptmr)
b lé Documentation Iptmir_hal SDK_532K144_03 532 SDK HAL for Low Power Timer (Iptmr)
b ;‘f Project Settings & lpuart SDK_S32K144_03 532 SDK Peripheral Driver for Low Power Universal Asyr
2§ Processorbxpert.pe Ipuart_hal SDK_S32K144 03 532 SDK HAL for Low Power Universal Asynchronous R
& mpu SDK_S532K144_03 532 SDK Peripheral Driver for Memory Protection Unit (|
- m mpu_hal SDK_532K144 03 532 SDK HAL for Memeory Protection Unit control (MPLE‘
1 projectl &% =] @8 osif SDK_S32K144_03 532 SDK Peripheral Drivers QS Interface (osif)
K- T pec_hal SDK_S32K144 03 532 SDK HAL for Peripheral Clack Control (PCC HAL)
» = Generator Configurstions A pdb SDK_532K144 03 532 SDK Peripheral Driver for Programmable Delay Bloc
- il b hal SNk S22K144 N2 S22 SNK HAI for Prn Nelav Rlnck (BNR HALT T
> (= 05s j

ol i
4 (= Processors
» ) CpuiSa2K144_100 Filter on for 532K144 100 (projectl)

4 (= Components

» (= Referenced Components 8 main.c 2 = o
» {3 pin_mucPinSettings &/ =
> 3 clockManl:clock_manager ;119"‘”5 : 222:1; |E‘
== rocessor 1 1=
> 0] intManLinterrupt_manager abstract
> |73 Ipuartl:lpuart] E13 Main module.
{[Inspector]) This module contains user's application code.
Inspector - Pinned e
Code Generation L4 No public methods
Select Distinct/Shared Mode
Open File v
main.c -
¥ | Component Enabled -
B Copy Ctrl+C
Console ¥ =8
B Paste Cirl+V
Build Configurations » ’ Resource Path Location Type

Change Repository...

Remove Component(s) from Project Delete
Doxygen Documentation

Help on Compenent

SDKs

Configuration Registers »

& Ipuartl:lpuart

Figure 9 Addition and opening LPUART component
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5. After configuring the parameter from U, click on generate code button (# ), and the
configuration will be generated in Generated_Code. In the same time the LPUART
driver will be added to project.

“ C/C++ - project]/Generated_Code/lp

File Edit Source Refactor MNavigate Search Project Run ProcessorExpert Window Help

il S B~ R-mpEiE GO R Gy LN LR N =R Hrirto oo Quick Aceess | £ | [EFCIC )
[ Project Bxplorer 52 [ %[ & ¥ = B £y Component Inspector - lpuartl 32 £y Components Library [Basic JAdvanced (5 = & v = B | §
+ [§) clockMan.c < et ﬂ o=
> [B clockManLh roperties . Methods
> % Cpu.c L Componentname  Ipuartl i@
» [ Cpuh
LPUARTO -
> [& dmaControllerl.c Device &
.+ [§_dmaControllerLh Component version  $32K144_SDK01
> [ lpuartLc] Configurations *._Shared compenents| Inherited components |
» [n] Ipuartl.
> [g esifle State structure name  Ipuart]_State =
> [ osifLh e —
» [8 pin_musc >>|| Configurations list 1
> [H pin_muxh # Configuration _Name Type Read only configuration  Transfer type  Baud rate Parity mode  Stop bits Bits per char
» (5 Project Settings/Startup_Code 0 Ipuartl_ InitConfigd || Ipusrt user config t Interrupts B ~ Disabled 1 8
4 (2 SDK
4 (= platform = =
» G devices
4 [= drivers i il
4 (= inc ¥ r
» [i clock managerh —
> [ edma_driverh main.c g lpuartl.c 52 = 0
» [§] interrupt_ manager.h i+ HODULE Lpartl. -/ "
| ol Ipuart_driverh |
» Ihl nins drnver. 2 #include “lpuartl.h”
- Components - project] 3 EI /=1 lpuartl configuration g == ]
B Eb B const lpuart_user_config & lpuartl_InitConfige |- { =
. - .transferType = LPUART UTVE™ e
» (= Generator_Configurations - pmnete © sool, ]
b (= O3s .parityMode = LPUART PARTTY DISABLED,
4 (= Processors .stopBitCount = LPUART ONE_STOP_BIT,
. @ Cpu:s32K144 100 .bitCountPerChar = LPUART 8 BITS_PER_CHAR,
4 (= Components .rxDMAChannel = @U,
» G Referenced Components | Dohachannel = au, s
> U5 pin_muxPinSettings
> B3 clockManl:clock_manager | 8 Problems 52 | &) Tasks &) Console @ =08
> &4] intManL:interrupt_manager 0 items
4 & Ipuartlilpuart o > = 2 path Lot .
* B lpurt_haltspuert_ha escription esource a ocation ype
[ LPUART_DRV_Init
[ LPUART_DRV Deinit

I LPUART_DRV InstallRxCallback L
I LPUART_DRV InstallTxCallback

I LPUART_DRV_SendDataBlocking

T LPUART_DRV_SendData

I LPUART_DRV_GetTransmitStatus -

Figure 10 LPUART configuration and driver

6. The generated configuration can be used with driver API, see LPUART example for
specific details regarding the configuration structure usage.
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