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Chapter 1
Introduction

The S32 Software Development Kit (S32 SDK) is an extensive suite of robust hardware
interface and hardware abstraction layers, peripheral drivers, RTOS, stacks and
middleware designed to simplify and accelerate application development on NXP S32K
microcontrollers.

This manual explains how to use the S32 SDK product, including the use with S32 Design
Studio, for easier application creation and configuration with graphical user interface.

1.1 System requirements

Hardware * 1.8 GHz processor
* 2 GB of RAM

Operating System Microsoft® Windows® 7.

Gnu Make For usage without S32 Design Studio.

Supported Compiler For usage without S32 Design Studio. See release
notes for supported versions.

Disk Space Approximately 150 MB of free disk space (when
installing standalone)

NOTE
The S32 Design Studio software development tools requirements
are covered by their own Quick Start Guide. PEx graphical
configuration tool can only be used with S32 Design Studio.

1.2 Installing S32 SDK

1.2.1 Bundled in S32 Design Studio

S32 SDK is delivered bundled in the S32 Design Studio. In this case it’s already configured
and ready to use.

1.2.2 Standalone

S32 SDK is also delivered through a standalone installer. Using the standalone installer is
recommended when using a compiler which is not supported in S32 Design Studio or
S32 SDK Quick Start Guide, Rev. 1.5, 04/2018
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when the graphical interface is not required. In this case the installer can configure an
existing S32 Design Studio to use the configuration files delivered in the installer.

If the integration with the S32 Design Studio is not needed the path to S32 Design Studio
can be left empty — and in this case, only the S32 SDK will be installed and configured.

1.3 Release Notes

Before using the S32 SDK, read the release notes. These notes contain important
information about last-minute changes, bug fixes, incompatible elements, or other topics
that may not be included in this manual. The product comes with the release notes
installed.

1.4 Terminology

The following are some of the terms used in the document.
Table 1-1. Terminology

Term Description

S32 SDK Software development kit that provides comprehensive software support for
NXP S32 devices. The S32 SDK includes a Hardware Abstraction Layer (HAL)
for each peripheral and peripheral drivers built on top of the HAL. S32 SDK
also contains the latest available RTOS kernels, a LIN stack and SBC
middleware to support rapid development on supported S32K devices.

Processor Expert Rapid application design tool targeted for NXP microcontrollers providing the
following key features:
» A Graphical User Interface which allows an application to be specified by
the functionality needed.
* An application created from Embedded Components encapsulating
initialization and functionality of basic elements of embedded systems.
» An automatic code generator which creates tested and optimized C code
which is tuned to your application needs and the selected NXP device.
* A built-in knowledge base, which immediately flags resource conflicts and
incorrect settings, so errors are caught early in design cycle allowing you
to get to market faster with a higher quality product.
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Chapter 2
Working with Projects

This chapter explains how to use the S32 Design Studio to create and work with S32
SDK projects.

A project organizes files and various compiler, linker, and debugger settings associated
with the applications or libraries you develop. S32 New Project wizard can be used to
create projects that group these files and settings into build and launch configurations.

2.1 Creating and building S32DS project

The New S32DS Project wizard help you to quickly create new projects. The wizard
generates a project with placeholder files and default settings (build and launch
configurations) for specified target. After the project has been created, you can easily
change any default setting to suit your needs.

To create a S32 SDK project using the New S32DS Project wizard:
1. Launch the S32 Design Studio. Please refer to S32 Design Studio documentation.

2. Select File > New > New S32DS Project, from the IDE menu bar.
The New S32DS Project page of the New S32DS Project wizard appears.
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B 53205 Application Project

Create a 532 Design Studio Project
MNew 53205 Application Project

Project name:

| project'l|

Use default location

Location: | Ri\workspaces_user\workspaceS32D5.ARM.2018.R1_new\project] Browse...
Processors: ToolChain Selection:
type filter text Core Kind MName Teolchain
w (= Family 532K T A MOplus Cortex-M0+ ARM Bare-Metal 32-bit Target Binary Toolchai w
B S32K144
522K116 Description :
532K113 GCC toolchain v.6.3 is selected ~
B s32K142 v v
@ < Back Mext » Finish Cancel

Figure 1 New S32DS Project page
3. Specify a name for the new project. For example, enter the project name as s,oject1.
4. Select the Processor you want to use from EIf S32DS project tab

5. Click Next, The New S32DS Project for <CPU_NAME> page of the New S32DS
Project wizard appears
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B 53205 Application Project

New 532DS Project for 532K118

Select required cores and parameters for them.

Project Marme brojecﬂ

Core Cortex-MO+

Library EWL ~
I/Q Support Ne /O -
FPU Support Toolchain Default >
Language s =
SDKs Cl
Debugger PE Micro GDE server -
@ < Back MNext » Cancel

Figure 2 New S32DS Project for <CPU_NAME> page

6. Click on -/ button to select from available SDKs, The Select SDK page of the New
S32DS Project wizard appears

B select sDK

7. Select the latest version of SDK, and then click OK.

Mame Yersion Type SDK description Edit/Show info...
[ 532K118_5DK 1.8.8 Contributed SDK 532K118 EAR SDK for GCC, GHS, |AR ] ,
Clone from git
Figure 3 Select SDK page

8. Review the settings and click Finish, project should be created and default view
should be presented.
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n workspaceS32D5.ARM.2018.R1_QSG - C/C++ - project]/Sources/main.c - 532 Design Studio for ARM

File Edit Source Refactor Mavigate Search Project Run  ProcessorExpert Window Help

Amilg 8- QR-BICFHF@g-a8-E-F-%$-0- Q- @ F-{JPE M| SiF 5 iH-FH-" MG
| 1 |1
r(\jProject Explorer &3 = <===D ¥ =0 %Component Inspector - pin_mux &3 ’%:Z"'C:'i"i_t'.”_. Basic Advanced j 2= ¥ =0 EE Qutli... & (® Bu = 0O
[ project1: Deb 4 W -
projectl: Debug Routing *._ Functional Properties Methodq Se‘d:mgsj = = X @ *
= Cpuh
View Mode Options ®" eit_code: volatile int
@® Collapsed  OPins [ Show Only Cenfigurable Signals @ main{veid) : int
aoc| can| omp|reao| Fim| GPio| JTAG|m LPiac|m LpsPI|  LPTMR|m LPUART|  Platform
Signals Pin/Signal Selection Direction Selt
w ADCO
ADC Channel 0 PTAC Input
ADC Channel 1 PTAT Input
ADC Channel 2 PTAE Input
< >
[£] mainc &2 = B8
Bl Filename : main.cl] A
%5, Components - project! 3 = B8 /*!
* [@file main.c
El ‘/ = * [@version @1.0@
= Generator_Configurations * fibrief
= 0Ss Main module.
. b This module contains user's application code.
v (= Processors w
4P Cpu:S32K118_64 o /%1
v (= Components **  (faddtogroup main_module main module documentation
Ui pin_mucPinSettings *=* s
) clockMan1:clock_manager g 2
ﬁj intMan:interrupt_manager [#7 Problems £2 Tasks Console Properties = =8
0 iterns
Description Resource Path Location Type

m| Writable | Smart Insert | 2:1

Figure 4 Default view after project creation

9. Processor Expert components can be observed the Components View, to add new
components open Component Library. (which can be opened from toolbar menu
Windows -> Show View)

10.Generate the driver configuration by clicking on # (or using toolbar menu Project
-> Generate Processor Expert Code). The generated configuration will be placed in
Generated_Code folder in project.

11. Start project build by clicking on % or invoking right click menu on project and
selecting Build Project.
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2.2 Importing an existing project

This section explains how to import an existing S32 Design Studio SDK project in S32

Design Studio.

To import an existing project:

1. Select File > Import, from the IDE menu. Choose import source page will appear.

File

Edit Source Refactor

Navigate Search Pr

|

L. &

New

Open File...
Close
Close All
Save

Save As..,
Save All
Revert
Move...
Rename...

Refresh

Convert Line Delimiters To
Print...

Switch Workspace
Restart

Import...
Export...

Properties

Exit

Alt+Shift+N »

Ctrl+W

Ctrl+Shift+W

Ctrl+S

Ctrl+Shift+S

F2

F5

Ctri+P

Alt+Enter

Figure 5 Select import option
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2. Expand General tree and Select Existing Projects into Workspace

n Import

Select

Choose import wizard, I @ - ”

Select an import wizard:

type filter text

s [ General A

Archive File
rﬁg Existing Projects into Workspace
[, File System
[ Preferences
[} Projects from Folder or Archive
= CfC++
= Component Development Environment
= Git
= Install
= Processor Expert
= Rernote Systems
= Run/Debug
(== 532 Design Studio

o Toams

L S W W W S W W W

@ < Back Next > Finish Cancel

Figure 6 Choose import source

3. Click Next. The Import projects screen appears.
4. Click Browse and select the example folder from SDK installation directory to
search for an existing Eclipse project.
NOTE
When using the S32 SDK bundled inside S32 Design Studio the
example folder is located in <S32 Design Studio install>
\S32DS\S32_SDK_<RELEASE_VERSION>\examples
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5. Select the project you want to import in your Workspace (It is useful that Copy to
Workspace is selected in this window. In this way the original project will be
preserved).

6. Click Finish. The imported project will appear in the Project Explorer view. Similar
to Default view after project creation.

2.3 Using New Project From Example

S32 Design Studio provides support for accessing the examples from the S32 SDK using
the New Project from Example. To use this feature follow the next steps:

1. Select File -> New -> New S32DS Project From Example. The following
window will appear.

532D5 Project frem Example.

Create 532D5 Project from Example

Project name: |

| Enter search text... |

Examples: Description:

» [ 532D5S Example Projects A
= 532D5 MOX 4.2 Halo 0.6 Exarnple Projects
(= 532K116 EAR SDK v1.8.7 Example Projects

w (= 532K118 EAR SDK v1.8.8 Example Projects
w = 532K118

w [ demo apps
& hello world s32k118 )
= izeled_freemaster s32k118
= lin_master_s32k118
= lin_slave_s32k118
(= touchsense_s32k118
v = driver_sxamples
v = analog
= cmp_dac_s32k118
% [= communication
(= flexio_i2c_s32k118
= flexio_i2s_s32k118
= flexio_spi_s32k118
= flexio_uart_s32k118

S e

® Finish Cancel

Figure 7 New Project from Example
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2. Select the desired project from the release version and click on Finish. The project
will be copied in your workspace.

2.4 Using a Makefile Project

To build a Makefile project without S32 Design Studio the system needs to have a make
utility (GNU version 3.0 and above, or equivalent) and a supported compiler. Please
refer to S32 SDK Release Notes for a list of supported compilers and their supported
version. Example projects are delivered for all supported compilers.

The makefile projects assumes that the make utility and corresponding compiler are
included in path.

1.
2.

Open a command line window (Start->Run->cmd.exe)
Navigate to project folder - makefile project are locate in example folder.

NOTE

Please check Release Notes or S32 SDK documentation for list
of available makefile projects

Execute make all command. This, depending on the used makefile, will generate one
or more elf files.

NOTE

For not relying on System PATH variable the user can temporary

modify the PATH variable as follows:
set PATH=%PATH%;<path to make>;<path to compiler>

The elf files can be deployed using one of the supported debugger. Please refer to
debugger documentation for flashing and debugging the application.
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Example:

Sinrod exanplessS532Kid4sdemo_appssblinking_LEDGCC—MKF
Sisexampless532Ki44~demo_appsshlinking_ LEDS~GCC—MKF*make all

Checked for uname.

found: MINGW3I2_NT-6.1

Azsuming Unix like environment

Compiling

Compiling

Build completet?

SovexamplessS532Kli44 v demo_appsshblinking_LEDSNGCC-MHEF >dir
Uolume in drive 5 iz Primary
Uolume Serial Humber is BCP4-DCFE

Directory of S:-“examplessS532Kid4d~demo_appssblinking_LEDSGCC—MKF

A2-8%.-2017
Az-a%-2017
az-a%-2817?7
Az-a8%.-2017
az-a%-2817?7
Az2-8%.-2017
az-a7-28a17?
Az-a87.-2017
az-a%2-28a17?7

A4:58
A4:58
A4:58
A4:5@
A4:58
A4:5@
A5:12
As:12
a4:58

<DIR> -
<DIR> --
L6854
22.485 app_flash.map
L5.681
21.195 app_ram.map
4.14% HMakefile
3.747 Makefile-arm
<DIR> obj

6 Fileds> 163,311 hytes
3 Dir<s>» 282.046.857.216 bytes free

2.5 Debugging Projects

When you use the S32 Design Studio to create a new project, the wizard sets the
debugger settings of the project's launch configurations to default values. You can
change these default values based on your requirements.

To debug a project, perform these steps.

1. Launch the IDE and have a project opened and selected.
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NOTE
Please ensure that the current perspective is C/C++ or Debug.
Current perspective is indicated usually in upper right corner in
eclipse window. Use Window -> Open Perspective to change
current eclipse perspective. Use Window-> Reset perspective to
reset all the Views to their default location and visibility.

2. Click * The Launch Configuration Selection dialog appeatrs.
Alternatively, you can select Run > Debug Configurations from the IDE menu bar.
NOTE
The launch/debug configurations are populated with the default
settings; these might need to be adjusted to accommodate various
configuration. Please refer to S32 Design Studio documentation
for Launch configuration settings.

3. Select the launch configuration you want to debug.

i N

-7 | Select Configuration (=l 2

Select a configuration to launch:

fc] projectl_Release
[c]projectl_Debug_RAM
[c]projectl_Debug

=y .

L -

Figure 8 Select launch configuration

4. Click OK. The IDE uses the settings in the launch configuration to generate
debugging information and initiate communications with the target board.
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2.6 Graphical Configuration of Drivers

The simplest way to configure the driver is to use the Processor Expert configurator
available in S32 Design Studio. Alternatively, the configuration can be written manually
in a text editor.

Here are the steps requires to graphically configure a driver:

1. Launch the IDE

2. Open Components View (double click on ProcessorExpert.pe file from project or
from toolbar Window->Show View ->Components)

3. If the desired component is not in Components View, open Components Library
(Windows -> Show view) and double click on desired component

4. If the need component is in Components View, right click on it and select Inspector
from context menu.

. workspace532D5.ARM.2018.R1_Q5G - C/C++ - project]/Sources/main.c - 532 Design Studio for ARM

File Edit Source Refacter MNavigate Search Project Run  ProcessorExpert Window Help

D-HR ®-§-GBCFEF A & E-C i~ 0 -~ ® & SRR WA BRSNS TR AR R iR
=] @ |
[ Project Explorer 32 BE& Y= 0 ’% Component Inspector - lpuart %I( ® =0 E= Qutli... I Bu = 0
~ =% project1: Debs LR @ =
et = Alphabetical “. Categories| Processors| Board Configurations 5 1% W *
!l Includes o Cpuh
£ Generated Code T SDK_532K113_10 || Applicable to project ~ ®" exit_code: volatile int
(5 Project Settings @ main(void) : int
(5 SDK Compenent Compenent Repository Description 2
@ _50“"55 & Ipizc SDK_S32K118_10 532 SDK Peripheral Driver for Low Pow
@ include _ & Ipit SDK_532K118_10 532 SDK Peripheral Driver for Low Pow
f;—f Documentstion & Ipspi SDK_S32K118_10 532 SDK Peripheral Driver for Low Pouw
5§ Processorbupert pe &y Iptmr SDK_S32K118_10 532 SDK Peripheral Driver for Low Pow
@ lpuart SDK_S32K118_10 532 SDK Peripheral Driver for Low Pow
IE_CI] mpu SDK_S32K118_10 532 SDK Peripheral Driver for Memory
Bl s el SDK_S32K118_10 532 SDK Peripheral Abstraction Layeri
@ SDK 532K118 10 532 SDK Peripheral Abstraction Laveri ¥
Inspector - Pinned 2
Code Generation » |64 (project)
Select Distinct/Shared Mode = "
Open File * hame : main.cf] ~
\f Compenent Enabled
& Copy Ctrl+C LE:ILTBB
(= Gener [} Paste Ctrl+V
= 0Ss lain module.
+ = Proces Build Configurations » [his medule centains user's application code.
P Cp Change Repository...
. Co | . . .
w L‘JE r||1{|:: Remove Compenent(s) from Praject Delete oup main_medule main module documentation .
=)
{5 pin Doxygen Documentation >
@Jclo Extras 4 as Console <= =
4| int Auto Test ¥
I U ~
@ i Description Resource Path Location Type
= Ipuartl:lpuart B [

Figure 9 Addition and opening LPUART component
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5. After configuring the parameter from Ul, click on generate code button (&), and the
configuration will be generated in Generated_Code. In the same time the LPUART
driver will be added to project.

| A R G + g A - ] X
|
| File Edit Source Refactor Navigate Search Project Run  Processor Expert Window Help
- HR e - R B E S E- O % -0 - Q- @I IREM | SiF e
[ e 5 |18
rﬁl Project Explorer £3 = <<===:> ¥ =0 % Component Inspector - [puart] &2 ’% Components Library Basic Advanced j = ¥ =08 =
[¢] dmaController].c A _ E;
Properties . Methods -
[A] dmaController!.h ®
@ Compenent name
lpuartl h
[m lpua Device LPUARTD v
[ pin_mux.c
m pin_muzxh Compenent version  532K144_5DK01
(2 Project_Settings Configurations . Shared components
v = SDK
~ [= platform »» || | State structure name | lpuart_State
(> devices Confi - -
it list -
v = drivers onfigurations li +
v = inc # Configuration  Name Type Read enly configuration  Transfer type  Baudrate Parity mo

[#] clock_manager.h 0 Ipuartl_InitConfigh §lpuart_user_config_t Interrupts 9600 Disabled

[R] edma_driverh

| @ interrupt_manager.h ¥
|
- (8] pins_driverh v main.c lpuartl.c &3 = 08
src
| ~
‘&5. Compenents - project E3 = B8 /*! lpuartl configuration 5 i
const lpuart_user_config_t flpuartl_InitConfiglj= {
| ST .transferType = LPUART_UsSTRE™ Ty
| (= Generator_Configurations .baudRate = gseeU,
= 08s .parityMode = LPUART_PARITY DISABLED,
|+ (= Processors .stopBitCount = LPUART _ONE_STOP BIT,
ess0 .bitCountPerChar = LPUART 8 BITS PER_CHAR,
@ Cpu:532K118_64 .rxDMAChannel = au,
v (= Components LtxDMAChannel = 8U,
(= Referenced_Components 1 w0
Ui} pin_muwxc:PinSettings
£ clockMan1:clock_manager [2 problems 52 Tasks Console Properties ¥ = 8
ﬂ] intMan1:interrupt_manager 0iterns
@ Ipuart1:lpuart ~
Description Resource Path Location Type

Figure 10 LPUART configuration and driver

6. The generated configuration can be used with driver API, see LPUART example for
specific details regarding the configuration structure usage.
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