Keil Logo

µVISION: Save, Compile, Flash, and Debug


Information in this article applies to

  • µVISION 4 and 5

Question

Is there an all in one shortcut in Keil, like "save, build, flash, and debug"?

Answer

Yes. You can check a few options to chain these together:

For saving files: go to Edit -> Configuration, and check "Save Files before entering Debug" (and optionally, check "Save Project before entering Debug" to save .uvprojx file).

For Flashing: go to Project -> Options for Target -> Utilities Tab and check "Update Target before Debugging"

Now you will save and flash when clicking Debug.

To Save, Build, Flash, and Debug when clicking the build button, go to Project -> Options for Target -> User Tab and check "Start Debugging".

More Information

  • Refer to User for more information on User Options
  • Refer to Editor for more information on Editor Settings.
  • Refer to Utilities for more information on Utilities settings.

Last Reviewed: Wednesday, February 20, 2019


Did this article provide the answer you needed?
 
Yes
No
Not Sure
 
  Arm logo
Important information

This site uses cookies to store information on your computer. By continuing to use our site, you consent to our cookies.

Change Settings

Privacy Policy Update

Arm’s Privacy Policy has been updated. By continuing to use our site, you consent to Arm’s Privacy Policy. Please review our Privacy Policy to learn more about our collection, use and transfers
of your data.