Keil Logo

ULINK: ULINKplus initialization file does not work for digital I/O


Information in this knowledgebase article applies to:

  • ULINKplus with MDK 5.25 pre-release

SYMPTOM

When debugging with a ULINKplus, the digital I/O lines are not getting initialized, even though the project uses an initialization file written to do this.

CAUSE

  • The digital I/O lines do not initialize properly when using this combination of settings:
  • The project uses an initialization file to initialize the ULINKplus digital I/O lines and the shunt value for power measurement. For example: [MDK_Installation_path]\ARM\ULINK\Template\Debug_UlinkPlus.ini
  • Under Project→Options for Target→Debug tab, Run to main() is checked
  • Use of the MDK 5.25 pre-release version

RESOLUTION

There is an easy workaround for this issue. Do the following things:

  • Disable the option Run to main() in the dialog Options for Target→Debug
  • Specify the file Debug_UlinkPlus.ini as usual in the dialog Options for Target→Debug
  • Add the command g ,main to the end of the Debug_UlinkPlus.ini file

STATUS

This issue will be solved in MDK version 5.25 or later.

MORE INFORMATION

Last Reviewed: Thursday, January 18, 2018


Did this article provide the answer you needed?
 
Yes
No
Not Sure
 
  Arm logo
Important information

This site uses cookies to store information on your computer. By continuing to use our site, you consent to our cookies.

Change Settings

Privacy Policy Update

Arm’s Privacy Policy has been updated. By continuing to use our site, you consent to Arm’s Privacy Policy. Please review our Privacy Policy to learn more about our collection, use and transfers
of your data.