Keil Logo

ULINK: problem using ULINKpro with audio/video device on same root hub


Information in this knowledgebase article applies to:

  • ULINKpro

SYMPTOM

When we use an ULINKpro to a capture high frequency trace while using some other audio/video USB device on the same root hub as the ULINKpro, trace capture sometimes fails and we see Trace: Communication Error in the trace status display in the µVision status bar. What is the reason for this?

CAUSE

Audio and video USB devices usually use isochronous endpoints, which have guaranteed bandwidth and have higher priority than bulk endpoints, which are used by ULINKpro.

Therefore using audio/video devices (Isochronous endpoints) with high bandwidth allocation and ULINKpro (Bulk endpoints) on the same root hub can influence ULINKpro operation under certain circumstances.

Normally this should not be a problem. But when high frequency trace is being captured then trace data can be lost (Overrun error) or due to delays in responses, it can even lead to unrecoverable errors such as "Communication Error".

RESOLUTION

It is recommended that ULINKpro is not combined with such devices on the same root hub. ULINKpro communication should then not fail because of bandwidth limitation.

MORE INFORMATION

Last Reviewed: Tuesday, April 4, 2017


Did this article provide the answer you needed?
 
Yes
No
Not Sure
 
  Arm logo
Important information

This site uses cookies to store information on your computer. By continuing to use our site, you consent to our cookies.

Change Settings

Privacy Policy Update

Arm’s Privacy Policy has been updated. By continuing to use our site, you consent to Arm’s Privacy Policy. Please review our Privacy Policy to learn more about our collection, use and transfers
of your data.