Keil Logo

µVISION DEBUGGER: ST-Link Does Not Connect to STM32F4 Discovery Board


Information in this knowledgebase article applies to:

  • MDK-ARM V4.62a

QUESTION

When I connect the STM32F4 Discovery board to µVision the ST-Link driver doesn't find the STM32F4 device on the Discovery board. I have the 2 jumpers at CN3 and the J1 jumper installed.

How do I fix this?

ANSWER

First, try uninstalling and re-installing the ST-Link driver in Windows. To do this, perform the following steps:

  1. Open the Windows Device Manager window (Start button, right-click Computer, click Properties, Advanced System Settings, Hardware tab, click Device Manager).
  2. With the STM32F4 Discovery board plugged in, find the ST-Link Dongle under Other Devices, and right-click it to display the context help menu.
  3. Unplug the USB cable from the STM32F4 Discovery board.
  4. Click Uninstall on the ST-Link Dongle context help menu.
  5. Plug the USB cable back in the STM32F4 Discovery board. ST-Link Dongle should now display in the USB Controller section.

µVision should find the STM32F4 device now.

If µVision still doesn't find the device, download and install the ST-Link V3.1 utility, then perform the uninstall/re-install sequence above again. Then the ST-Link driver should connect properly and µVision should find the STM32F4 device.

SEE ALSO

FORUM THREADS

The following Discussion Forum threads may provide information related to this topic.

Last Reviewed: Monday, February 4, 2019


Did this article provide the answer you needed?
 
Yes
No
Not Sure
 
  Arm logo
Important information

This site uses cookies to store information on your computer. By continuing to use our site, you consent to our cookies.

Change Settings

Privacy Policy Update

Arm’s Privacy Policy has been updated. By continuing to use our site, you consent to Arm’s Privacy Policy. Please review our Privacy Policy to learn more about our collection, use and transfers
of your data.