Keil Logo

µVISION DEBUGGER: SOURCE BROWSER PROBLEMS IN ASSEMBLER KIT


Information in this article applies to:

  • µVision Version 2.05

QUESTION

I just received the A51 Assembler Kit and I'm having trouble with the µVision Debugger. I have code that compiles and I can run it on our board. I made some changes for the debugger and the source browser.

  1. When I start the debugger I get a message saying I am running the evaluation version.
  2. When I try to use the source browser it tells me to check the box "build browse information" under target-options/output and then rebuild my target. If I do this, it still gives the same error repeatedly.

Can you give me any suggestions?

ANSWER

The problems you have encountered are associated with the A51 Assembler Kit and are detailed below:

  1. The full, unlimited debugger is NOT included with the A51 Assembler Kit. To help customers get started, we include a DEMO/EVAL debugger in kits that don't include the full, unlimited debugger. It was our intention to help customers who don't purchase the high-end kits test small programs. The error message you see that tells you that the debugger is an evaluation version is correct.
  2. As for the source browser information, the C compiler generates source browser information, the assembler does not. There is no way to use the source browser in assembly-only programs.

Last Reviewed: Saturday, July 9, 2005


Did this article provide the answer you needed?
 
Yes
No
Not Sure
 
  Arm logo
Important information

This site uses cookies to store information on your computer. By continuing to use our site, you consent to our cookies.

Change Settings

Privacy Policy Update

Arm’s Privacy Policy has been updated. By continuing to use our site, you consent to Arm’s Privacy Policy. Please review our Privacy Policy to learn more about our collection, use and transfers
of your data.