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1 Concept

1.1 Introduction

This document is a general guide to use the SSE-310 MPS3 BSP pack. The CMSIS pack is to be used with the
Corstone®-310 platform MPS3 FVP model or AN555 FPGA (AN555: Arm Corstone™ SSE-310 with Cortex®-M85
and Ethos™-U65: Example Subsystem for MPS3). The pack contains necessary source files, a linker script file, and
a specification document to kick-start development for the Corstone-310 MPS3 platform, and a reference secure
side Blinky example to enable a user to understand uVision and IAR project configuration. The pack also provides a
System View Description (SVD) file for the platform to be used with the uVision and IAR debugger. This document
specifies system prerequisites and explains how to build and run the reference Blinky example on the SSE-310
MPS3 FVP model and on the AN555 FPGA.

Terms and Abbreviations:

Terms Meaning

BSP Board Support Pack

FVP Fixed Virtual Platform

FPGA Field Programmable Gate Array
VIO Virtual I/O

1.2 Prerequisites

e Developement Environments:
CMSIS-Toolbox v5.38. or IAR Embedded Workbench v9.40,

e Compiler:
Arm Compiler for Embedded (Version 6.20 or newer),
GNU Arm Embedded Toolchain Arm GCC (Version 11.3 or newer),
LLVM Embedded Toolchain for Arm (Version 17.0.1 or newer),
IAR C/C++ Compiler for Arm (Version 9.50.1 or newer),

e FVP model:
Corstone SSE-310 MPS3 FVP model,

e MPS3 FPGA:
AN555: Arm Corstone™ SSE-310 with Cortex®-M85 and Ethos™-U65 Example Subsystem for MPS3 FPGA,

e Package manager:
vCpkg.

e Python version 3.9 for VIO examples

Download Python3.9 like the following on Ubuntu if the version at apt is not working:

$ sudo apt-get update && sudo apt-get upgrade
$ sudo apt-get install -y make build-essential libssl-dev zliblg-dev libbz2-dev
libreadline-dev libsqlite3-dev wget curl 1lvm libncurses5-dev libncursesw5-dev
xz-utils tk-dev liblzma-dev tk-dev libffi-dev

$ wget https://www.python.org/ftp/python/3.9.18/Python-3.9.18.tgz
$ tar xzf Python-3.9.18.tgz && cd Python-3.9.18

$ ./configure --prefix=/opt/python/3.9.18/ --enable-optimizations
$ make -j "$(nproc)"
$ sudo make altinstall

$ export PYTHONHOME=/opt/python/3.9.18



https://github.com/Open-CMSIS-Pack/cmsis-toolbox
https://www.iar.com/products/architectures/arm/iar-embedded-workbench-for-arm/
https://developer.arm.com/Tools%20and%20Software/Arm%20Compiler%20for%20Embedded
https://developer.arm.com/downloads/-/gnu-rm
https://github.com/ARM-software/LLVM-embedded-toolchain-for-Arm
https://www.iar.com/products/architectures/arm/iar-embedded-workbench-for-arm/
https://developer.arm.com/tools-and-software/open-source-software/arm-platforms-software/arm-ecosystem-fvps
https://developer.arm.com/tools-and-software/development-boards/fpga-prototyping-boards/download-fpga-images
https://learn.arm.com/learning-paths/microcontrollers/vcpkg-tool-installation/

1.3 Documents
1. Corstone-310 FVP Technical Overview: contains overview of the FVP and its features.

2. Arm Corstone™ SSE-310 with Cortex-M85 and Ethos™-U65: Example Subsystem for MPS3: contains overview
of the FPGA and its features.

3. Arm Corstone SSE-310 Subsystem Technical Reference Manual: contains the specification of the architecture
of the subsystem, description of several interfaces (address, data width, clock/power/reset domain), functional
description of the components.

SSE-310 MPS3 BSP Pack contains additional documentation in the "Documents" folder.




2 Installing the Pack

2.1 CMSIS-Toolbox

To install the ARM: :V2M MPS3 SSE 310 BSP pack in command-line, use:

$ cpackget add ARM.V2M MPS3 SSE 310 BSP

This will install the prerequired ARM.CMSIS.6.0.0, ARM.CMSIS-Compiler.2.0.0 and ARM.DMA350.1.0.0 packages as

well.

2.2 |AR Embedded Workbench

Install ARM: :V2M MPS3 SSE 310 BSP using the CMSIS-Pack Manager. (Find:

Project > CMSIS-Pack Manager)

The pack can be browsed by selecting SSE-310-MPS3 device under ARM Cortex M85 Devices.

AR Embedded Workbench CMSIS Manager _ . IAR Embedded Workbench CMSIS Manager - o
Fle Edit Search CMSISManager Window Help File gmtq:eym CMSIS Manager  Window  Help | |
i E ety e | e Q Ele
Q-ig- i Bl oD 2 Q ®|e .
=g B Devices B Bozrds [ Exemples ) Console Bl Bmy|® 3 =0
= 8 @ Packs il Boards [ Examples =) Console ] Emorlog =8
= = Search Pack
et zelklo Pack Action Description
earch Device S 1oack 210Dz cplecien
Device Summary | > % ARMVZMMPS3 SSE 31085 (g5 Install ARM V2M-MPS3 Board Support PACK for CoreLink SSE-310 - TrustZone
« @ ARM 28 Devices T T P E Y e e CoRre N Ny To e Ie e S e
> 5 ARM.CMSIS [€ Ustadate | CMSIS (Common Microcontroller Software Interface Standard)
’ g ﬁgm g”:a :3 : g“f“ 3 5 ARM.CMSIS-FreeRTOS % Bundle of FreeRTOS for Cortec-M and Cortex-A
” ortex evice > % ARM.DMA35D ‘ Gate . Pack for the DMA3S0 drivers
> i ARM Cortex A9 1Device > %3 NXP.Component S Abstraction Leigy Install Software Pack for osa
> “ ARM Cortex MO 1 Device » g NXP EDGEFAST BT BLE ¢ Installs___ Software Pack for edgefast bluetooth
> 42 ARM Cortex MO plus 2 Devices > % NXPFATFS Install Software Pack for fatfs
> % ARM Cortex M1 1 Device > %3 NXP FREERTOS-KERNEL Install Software Pack for freertos-kernel
> %% ARM Cortex M3 1 Device > % NXPISSDK Install Seftware Pack for issdk
> %2 ARM Cortex M4 2 Devices > % NXP LITTLEFS Install Software Pack for littlefs
> % ARM Cortex MT 3 Devices > H NXPLWIP Install Software Pack for lwip
> % ARM Cortex M23 2 Devices > %3 NXP.MBEDTLS Install=___ Software Pack for mbedtls
5 % ARM Cortex M33 4 Devices > % NXP Middleware [ Install NXP Kinetis SDK Middleware Software Pack
5 42 ARM Cortex M35P 4 Devices > % NXPMMCAU ‘ Software Pack for mmcau
, %% ARM Cortex M55 2 Devices > % NXP Multicore stal NXP Kinetis SDK Multicare Software Pack
. > 5 NXP.SDMMC Install Software Pack for sdmmc
v % ARM Cortex Mi5 3 Devices > % NXP.USB Install Software Pack for ush
> % NXP.USB_PD < Install Software Pack for usb_pd
I SSE-310-MPS3_ANSS5 > F NXPWIFI Install+ Software Pack for wifi
B SSE-310-MPS3_FVP > % NXP WIRELESS_WPA_SUPPLICANT v Install= Software Pack for wireless.wpa_supplicant
> > % wolfSSLwolfSSL < Install Light weight SSL/TLS and Crypt Library for Embedded Systems

> % ARM SC300
> 4 ARMvE-M Baseline

1 Device

Figure 1: Selecting ARM: :V2M MPS3 SSE 316 BSP using IAR CMSIS-Pack Manager



3 Blinky example: CMSIS-Toolbox

You can see the example’s folder structure under Blinky example tree chapter. The following example will assume
the usage of a linux machine, therefore some commands might differ on Windows and Mac.

As the example contains a Makefile, you can use that as well, but we will go through in every configuration without
it as well.

3.1 Import

Copy the containing folder from the CMSIS Pack to your working directory, and provide it with the necessary permis-
sions:

$ cp -r ${CMSIS PACK ROOT}/ARM/V2M MPS3 SSE 310 BSP/1.4.0/Examples/Blinky blinky-example
$ chmod -R +w blinky-example
$ cd blinky-example

Then install the project dependencies:
$ vcpkg activate
Read more about vcpkg

3.2 Build

The examples support the [AC6, GCC, IAR, CLANG] compilers, which are represented as [armclang, gcc, iar,
clang] in the Makefile. And in default it builds all two variants of [MPS3 FVP, MPS3_ AN555].
Let’'s make a build with AC6 toolchain for the MPS3 FVP:

$ cbuild Blinky.csolution.yml --packs --update-rte --jobs $(nproc) --context .Debug+MPS3 FVP --toolchain
AC6

or

$ make armclang

If you just want to generate the .cprj project files, without building the whole project, you can use

L/y/ csolution

$ csolution convert Blinky.csolution.yml --toolchain [AC6, GCC, IAR, CLANG] --context
. [Debug, Release]+[MPS3 FVP, MPS3 AN555]

Used tags while building:

Tag Mandatory Meaning
—packs No Downloading packs required for the pack.
—update-rte No Overwrite RTE folder content from pack.
—ijobs [n] No Build on [n] threads.
—toolchain Yes Compiler Toolchain. If missing builds for all 4 compilers.
—context Yes Selecting the build type or board.
Select .Debug or .Release

See the help and documentation of cbuild for further help.

Binary:
Find the binary files in the following location:

build/{platform}/{toolchain}/{type}/{example}/outdir/Blinky. [axf,elf,out]
as
build/MPS3 FVP/AC6/Debug/Blinky/outdir/Blinky.axf


https://learn.arm.com/learning-paths/microcontrollers/vcpkg-tool-installation/

3.3 Run - Terminal

After building the target, you can launch the FVP, using the command:
$ <path to fvp>/FVP Corstone SSE-310 Ethos-U65 -a build/MPS3 FVP/AC6/Debug/Blinky/outdir/Blinky.axf

or, after setting the model path <path to fvp> in the Makefile:
$ make run-armclang

3.4 Run-FPGA

Make sure to rebuild the application with MPS3 AN555. If you translated with make, then you should already have
binary files in the bins/ folder. To translate the output elf file to binary, run the following command for the specific
compiler:

Compiler ‘ Command Arguments

armclang | fromelf --bin bins/an555/Blinky.axf -o bins/an555/Blinky armclang.bin
gcc arm-none-eabi-objcopy | -0 binary bins/an555/Blinky.elf bins/an555/Blinky gcc.bin

clang 1lvm-objcopy -0 binary bins/an555/Blinky.clang.elf bins/an555/Blinky clang.bin
iar ielftool --bin bins/an555/Blinky.out bins/an555/Blinky iar.bin

Copy the binary to the FPGA’s SD card (x:/SOFTWARE) and set the address in images.txt
(x:/MB/HBIO309C/AN555/images.txt) to 0x00000000, then restart the FPGA.

IMAGEOADDRESS: 0x00000000 ;
IMAGEOUPDATE: AUTO ;
IMAGEOFILE: /SOFTWARE/Blinky.bin ;

After uploading the example code, restart the FPGA and see the output on the LEDs and the serial output.



4 Blinky example: Keil Studio

You can see the example’s folder structure under Blinky example tree chapter.

To Use Keil Studio, install the Keil Studio Pack in Visual Studio Code

4.1 Import
Copy the containing folder from the CMSIS Pack:

$ cp -r ${CMSIS PACK ROOT}/ARM/V2M MPS3 SSE 310 BSP/1.4.0/Examples/Blinky blinky-example
$ chmod -R +w blinky-example

$ cd blinky-example

Then open your working directory in Visual Studio Code.

Or open from Visual Studio Code:
Go to CMSIS, then create a solution with SSE-310-MPS3 selected as the following:

) FEile Edit Selection View G

CMSIS e = Create Solution X

~ CONTEXT

Create New CMSIS Solution

No solutions found
Target Board Target Device Target Type

— V2M-MPS3-S5E-310 R SSE-310-MPS3_FVP 4 SSE-310-MPS3_FVP
No target types found

No build types found Templates and Examples

Blinky
* SOLUTION
Find an exam, tion for your

Solution Name

Blinky
Create a New Solution
Solution Location
Open an existing on project to
convert it to a

Convert a pVision Project v Initialize Git repository

v ACTIONS Cancel Create

%0 No Arm License

Figure 2: Keil Studio: Importing Blinky Project


https://marketplace.visualstudio.com/items?itemName=Arm.keil-studio-pack

4.2 Build
To build the example, open the CMSIS tab on the left side of Visual Studio Code, then click on Build.

) FEile Edit Selection View Go --- 2 Blinky
CMSIS Blinky.cprojectyml X
~ CONTEXT
Blinky
MPS3_FvP

Debug

Blinky

~ SOLUTION

~ ACTIONS
/ Build v P Run

E 3 Debug *

owershell
info cbuild: build finished successfully! e

Build complete Build
ﬂ Terminal will be reused by tasks, press any key to cleose it.

) 0  Blinky.Debug+MPS3_ FVP  No Arm License @ Environment In1,Col1 Sp 2 UTF8 LF YAML CMSIScproject [
Figure 3: Keil Studio: Building Project

Set compiler:

By default the project is built by GCC toolchain.

To build with other toolchain, add ’compiler: [AC6, GCC, IAR, CLANG]’ to Blinky.csolution.yml
under solution: tag, like:

12.

13. compiler: AC6

14. cdefault:

15.

Binary:
Find the binary files in the following location:

build/{platform}/{toolchain}/{type}/{example}/outdir/Blinky. [axf,elf,out]
as
build/MPS3 FVP/AC6/Debug/Blinky/outdir/Blinky.axf

4.3 Run - Terminal

After building the target, you can launch the FVP, using the command:
$ <path to fvp>/FVP Corstone SSE-310 Ethos-U65 -a build/MPS3 FVP/AC6/Debug/Blinky/outdir/Blinky.axf



4.4 Run-FPGA

Make sure to build the application with MPS3_AN555. To translate the output elf file to binary, run the following com-
mand for the specific compiler:

Compiler ‘ Command Arguments

armclang | fromelf --bin bins/an555/Blinky.axf -o bins/an555/Blinky armclang.bin
gcc arm-none-eabi-objcopy | -0 binary bins/an555/Blinky.elf bins/an555/Blinky gcc.bin

clang 1lvm-objcopy -0 binary bins/an555/Blinky.clang.elf bins/an555/Blinky clang.bin
iar ielftool --bin bins/an555/Blinky.out bins/an555/Blinky iar.bin

Copy the binary to the FPGA’s SD card (x:/SOFTWARE) and set the address in images.txt
(x:/MB/HBIO309C/AN555/images.txt) to 0x00000000, then restart the FPGA.

IMAGEOADDRESS: 0x00000000 ;
IMAGEOUPDATE: AUTO ;
IMAGEOFILE: /SOFTWARE/Blinky.bin ;

After uploading the example code, restart the FPGA and see the output on the LEDs and the serial output.

10



5 Blinky example: IAR Embedded Workbench

You can see the example’s folder structure under Blinky example tree chapter.

5.1 Import

To import the example, first you need to copy the project files, as shown in section 3. After copying the project, import
it the following way:

1. Create a new workspace, (File > New Workspace)
2. Open Create a new project window for importing csolution projects. (Project > Create New Project...)
3. Select tool chain: CMake for Arm
4. Select project template: Import csolution.yml
5. Click Next, navigate to the project folder and select the Blinky.csolution.yml file.
Before building

1. add 'compiler: TIAR’toBlinky.csolution.yml under solution: tag.
12.
13. compiler: IAR
14. cdefault:
15.

2. set CMake and CMSIS-Toolbox binary path.
The minimum version that supports IAR is 2.2.1.
Go to (Tools > Options... > CMake/CMSIS-Toolbox).

IDE Options

- Colors and Fonts

- Key Bindings Options entered here are used to inttialize new projects.
CMake
- Language
- Editor I CMake executable:  C:\Program Files\CMake \bin\cmake exe I

-~ Messages Extra command line options:
- Troubleshooting

Project

CMake/CMSIS-Toolbox CMSIS-Toolbox

ource Lode Control

.. Debugger || cusIS-Toolbox installation:  <CMSIS-TOOLBOX> bin -
- Stack Pack root:
- Terminal /O @ Add curent installation as IAR_TOOLCHAIN_ROOT

[ Automatically download missing packs (automatically accepts licenses)
[ Automatically resolve device
Csolution extra command line options:

Chuildgen extra command line options:

~update-te

Figure 4: IAR EW: Set CMSIS-Toolbox path

If you encounter issues while generating the project files, first make sure that you are using the
correct CMSIS-Toolbox version! Minimum 2.2.1.

Please refer to the CMSIS-Toolbox Installation Guide or install it with $ vcpkg activate.

11


https://github.com/Open-CMSIS-Pack/cmsis-toolbox/blob/main/docs/installation.md

5.2 Build

To build the example click on the "Make" button, or press "F7".

k1 - |AR Embedded Workbench IDE - Arm 9.40.1

File Edit View Project Simulator Tools Window Help

sh 0B @ e LD C s oo nnilel 0 250
‘Workspace v 0 X o

|Debug v|

Figure 5: IAR EW: Building the Blinky example

5.3 Run and Debug

This section explains how to run the Blinky example on the Corstone SSE-310 FVP model. First, download and
install the SSE-310 FVP from the link provided in the Prerequisites section.

To debug the example inside the IAR Embedded Workbench software, follow the steps below.

Start up the FVP with a CADI server:
<path to fvp>/FVP Corstone SSE-310 Ethos-U65.exe -S

Set up the debugger inside IAR:

Open the project Options, by clicking on the root file in the Workspace and then selecting it from the Project menu
item. (Project > Options)

Select the Debugger in the Category list and select CADI as Driver on the Setup tab.

Options for node "Blinky”

Category: Factory Settings

General Options

Static Analysis

Runtime Checking
C/C++ Compiler Setup Pownload Images Multicore Authentication Extra Options Plugins
Assembler
Output Converter Driver B Runto

Custom Buid rC”‘D' , main
Linker

; Setup macros
I ) Use macro file(s)
w

CADI
CMSIS DAP

— e

Figure 6: IAR EW: Selecting Debugger

You can select the desired CADI server in the CADI Category if there are more than one you wish
to use. Otherwise, it can be left empty.

To run the debugger click on the "Download and Debug" button. The application will be automatically loaded to the
model by the debugger.

12



5.4 Run - Terminal

After building the target, you can launch the FVP from the terminal, using the command:
<path to fvp>/FVP Corstone SSE-310 Ethos-U65.exe <path to bin>/Blinky.out

5.5 Run-FPGA

To translate the output elf file to binary, run the following command for the specific compiler:

Compiler | Command Arguments

armclang | fromelf --bin bins/an555/Blinky.axf -o bins/an555/Blinky armclang.bin
gcc arm-none-eabi-objcopy | -0 binary bins/an555/Blinky.elf bins/an555/Blinky gcc.bin

clang 1lvm-objcopy -0 binary bins/an555/Blinky.clang.elf bins/an555/Blinky clang.bin
iar ielftool --bin bins/an555/Blinky.out bins/an555/Blinky iar.bin

Copy the binary to the FPGA’s SD card (x:/SOFTWARE) and set the address in images.txt
(x:/MB/HBI®309C/AN555/images.txt) to 0x00000000, then restart the FPGA.

IMAGEOADDRESS: 0x00000000 ;
IMAGEOUPDATE: AUTO ;
IMAGEOFILE: /SOFTWARE/Blinky.bin ;

To debug the project:

1. Select the "CMSIS DAP" Driver, and connect to the running example afterwards.
(Project > Options > Debugger > Setup > Driver)

2. Click on "Run and Debug".

If you have are using a revision B board, use the HBIO309B directory. The examples are only
verified on the revision C boards.

Options for node “Blinky™

Catgory Factory Settings
General Options

Static Analysis

Runtime Checking

C/C++ Compiler ownload Images Multicore Authentication Extra Options  Plugins

Assembler
Output Converter Driver B Runto

Custom Build CMSIS DAP v main
Linker
Ruild Acti Setup macros

() Use macro file(s)

E2/E2 Lite

Figure 7: IAR EW: Select "CMSIS DAP" Debugger for MPS3 FPGA
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6 Vio example: CMSIS-Toolbox

You can see the example’s folder structure under Vio example tree chapter. The following example will assume the
usage of a linux machine, therefore some commands might differ on Windows and Mac.

As the example contains a Makefile, you can use that as well, but we will go through in every configuration without
it as well.

6.1 Import

Copy the containing folder from the CMSIS Pack to your working directory, and provide it with the necessary permis-
sions:

$ cp -r ${CMSIS PACK ROOT}/ARM/V2M MPS3 SSE 310 BSP/1.4.0/Examples/Vio vio-example
$ chmod -R +w vio-example
$ cd vio-example

Then install the project dependencies:
$ vcpkg activate
Read more about vcpkg

6.2 Build

The examples support the [AC6, GCC, IAR, CLANG] compilers, which are represented as [armclang, gcc, iar,
clang] in the Makefile. Let’s make a build with AC6 toolchain:

$ cbuild Vio.csolution.yml --packs --update-rte --jobs $(nproc) --context .Debug --toolchain AC6
or
$ make armclang

After building, make sure to provide a minimum of 8x600 memory to stack allocation.

In Vio/RTE/Device/SSE 310 MPS3 FVP/regions V2M MPS3 SSE 310 FVP.h modify
#define  STACK SIZE 0x00000200 to

#define  STACK SIZE 0x00000600

Then rebuild without - -update-rte.

Used tags while building:

Tag ‘ Mandatory Meaning
—packs No Downloading packs required for the pack.
—update-rte No Overwrite RTE folder content from pack.
—ijobs [n] No Build on [n] threads.
—toolchain Yes Compiler Toolchain. If missing builds for all 4 compilers.
—context Yes Selecting the build type or board.
Select .Debug or .Release

See the help and documentation of cbuild for further help.

csolution.
$ csolution convert Blinky.csolution.yml --context .[Debug, Release] --toolchain
[AC6, GCC, IAR, CLANG]

—/9 If you just want to generate the .cprj project files, without building the whole project, you can use

14


https://learn.arm.com/learning-paths/microcontrollers/vcpkg-tool-installation/

Binary:
Find the binary files in the following location:

build/{platform}/{toolchain}/{type}/{example}/outdir/Vio. [axf,elf,out]
as
build/MPS3 FVP/AC6/Debug/Vio/outdir/Vio.axf

6.3 Run - Terminal

Download arm_vio.py, like the following:

On Windows:

PS > wget https://github.com/ARM-software/AVH/raw/main/interface/python/arm vio.py -OutFile arm vio.py
On Linux:

$ wget https://github.com/ARM-software/AVH/raw/main/interface/python/arm vio.py -o arm vio.py

Then set verbosity = logging.DEBUG in it.

verbosity = logging.DEBUG

Figure 8: Setting debug mode in arm vio.py

Set environmental variables:

On Windows:

PS > $env:PYTHONHOME = ’'C:/Users/<user>/AppData/Local/Programs/Python/Python39’
On Linux:

$ export PYTHONHOME=/opt/python/3.9.18

After building the target, you can launch the FVP, using the command:
$ <path to fvp>/FVP Corstone SSE-310 Ethos-U65 -a build/MPS3 FVP/AC6/Debug/Vio/outdir/Vio.axf
-C mps3 board.v path=<path to vio py dir>

or, after setting the model path <path to fvp>and <path to vio py dir>in the Makefile:
$ make run-armclang

Remember to use the path of the containing folder of arm_vio.py when specifying path
<path_to vio py dir>.
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7 Vio example: Keil Studio

You can see the example’s folder structure under Vio example tree chapter.

To Use Keil Studio, install the Keil Studio Pack in Visual Studio Code

7.1 Import
Copy the containing folder from the CMSIS Pack:

$ cp -r ${CMSIS PACK ROOT}/ARM/V2M MPS3 SSE 310 BSP/1.4.0/Examples/Vio vio-example
$ chmod -R +w vio-example

$ cd vio-example

Then open your working directory in Visual Studio Code.

Or open from Visual Studio Code:
Go to CMSIS, then create a solution with SSE-310-MPS3 selected as the following:

) File Edit Selection View Go - 3 P Search

CMSIS = Create Solution X

~ CONTEXT

Create New CMSIS Solution

No solutions found
Target Board Target Device Target Type

2M-MPS3 =) SSE-310-MPS3_FVI 3SE-310-MPS3 .
No target types found CELRALE 0-MPS3_FVP v~ SSE-310-MPS3_FVP

No build types found Templates and Examples

Vio
* SOLUTION
ind xample csolution for your
Solution Name
Vio

Create a New Solution
Solution Location

Open an existing
convert it to a csoluti

Convert a pVision Project 1 Git repository

Meed help? Explo

v ACTIONS Cancel

¥ O ®oA0 W0 NoAm License

Figure 9: Keil Studio: Importing Vio Project
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https://marketplace.visualstudio.com/items?itemName=Arm.keil-studio-pack

7.2 Build
To build the example, open the CMSIS tab on the left side of Visual Studio Code, then click on Build.

) File Edit Selection View

CMSIS moe Vio.csolution.yml X

~ CONTEXT

MPS3_FVP

Debug

~ SOLUTION

main.c

Driver_USART_Common.h
~ ACTIONS

/ Build v P Run

E 3 Debug *

[ Bud o+ [0~

info cbuild: build finished successfully!
Build complete
ﬂ Terminal will be reused by tasks, press any key to cleose it.

Ln9 Col31 Spacess2 UTF-8 LF YAML CMs

Figure 10: Keil Studio: Building Project

After building, make sure to provide a minimum of 8x600 memory to stack allocation.

In Vio/RTE/Device/SSE 310 MPS3 FVP/regions V2M MPS3 SSE 310 FVP.h modify
#define  STACK SIZE 0x00000200 to

#define  STACK SIZE 0x00000600

Then rebuild.

Set compiler:

By default the project is built by GCC toolchain.

To build with other toolchain, add 'compiler: [AC6, GCC, IAR, CLANG]’ to Vio.csolution.yml
under solution: tag, like:

12.

13. compiler: AC6

14. cdefault:

15.

Binary:
Find the binary files in the following location:

build/{platform}/{toolchain}/{type}/{example}/outdir/Vio. [axf,elf,out]
as
build/MPS3 FVP/AC6/Debug/Blinky/outdir/Vio.axf
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7.3 Run - Terminal

Download arm_vio.py, like the following:

On Windows:

PS > wget https://github.com/ARM-software/AVH/raw/main/interface/python/arm vio.py -OutFile arm vio.py
On Linux:

$ wget https://github.com/ARM-software/AVH/raw/main/interface/python/arm vio.py -o arm vio.py

Then set verbosity = logging.DEBUG in it.

verbosity = logging.DEBUG

Figure 11: Setting debug mode in arm vio.py

Set environmental variables:

On Windows:

PS > $env:PYTHONHOME = ’'C:/Users/<user>/AppData/Local/Programs/Python/Python39’
On Linux:

$ export PYTHONHOME=/opt/python/3.9.18

After building the target, you can launch the FVP, using the command:
$ <path to fvp>/FVP Corstone SSE-310 Ethos-U65 -a build/MPS3 FVP/AC6/Debug/Vio/outdir/Vio.axf
-C mps3 board.v _path=<path to vio py dir>

or, after setting the model path <path to fvp>and <path to vio py dir>inthe Makefile:
$ make run-armclang

Remember to use the path of the containing folder of arm vio.py when specifying path
<path _to vio py dir>.
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8 Vio example: IAR Embedded Workbench

You can see the example’s folder structure under Vio example tree chapter.

8.1 Import

To import the example, first you need to copy the project files, as shown in section 3. After copying the project, import
it the following way:

1. Create a new workspace, (File > New Workspace)
2. Open Create a new project window for importing csolution projects. (Project > Create New Project...)
3. Select tool chain: CMake for Arm
4. Select project template: Import csolution.yml
5. Click Next, navigate to the project folder and select the Vio.csolution.yml file.
Before building

1. add 'compiler: TIAR’toVio.csolution.yml under solution: tag.
12.
13. compiler: IAR
14. cdefault:
15.

2. set CMake and CMSIS-Toolbox binary path.
The minimum version that supports IAR is 2.2.1.
Go to (Tools > Options... > CMake/CMSIS-Toolbox).

IDE Options

- Colors and Fonts

- Key Bindings Options entered here are used to inttialize new projects.
CMake
- Language
- Editor I CMake executable:  C:\Program Files\CMake \bin\cmake exe I

-~ Messages Extra command line options:
- Troubleshooting

Project

CMake/CMSIS-Toolbox CMSIS-Toolbox

ource Lode Control

.. Debugger || cusIS-Toolbox installation:  <CMSIS-TOOLBOX> bin -
- Stack Pack root:
- Terminal /O @ Add curent installation as IAR_TOOLCHAIN_ROOT

[ Automatically download missing packs (automatically accepts licenses)
[ Automatically resolve device
Csolution extra command line options:

Chuildgen extra command line options:
~update-te

Figure 12: IAR EW: Set CMSIS-Toolbox path

If you encounter issues while generating the project files, first make sure that you are using the
correct CMSIS-Toolbox version! Minimum 2.2.1.

Please refer to the CMSIS-Toolbox Installation Guide or install it with $ vcpkg activate.
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https://github.com/Open-CMSIS-Pack/cmsis-toolbox/blob/main/docs/installation.md

8.2 Build

To build the example click on the "Make" button, or press "F7".

- |AR Embedded Workbench IDE - Arm 9.40.1

File Edit View Project Simulator Tools Window Help

MR @ = 006D c - AQ 2 K2 B > A1 =0 + idh

‘Workspace v 0 X

|Debug v|

Figure 13: IAR EW: Building the Vio example

After building, make sure to provide a minimum of 8x600 memory to stack allocation.

In Vio/RTE/Device/SSE 310 MPS3 FVP/regions V2M MPS3 SSE 310 FVP.h modify
#define  STACK SIZE 0x00000200 to

#define  STACK SIZE 0x00000600

Then rebuild.

8.3 Run and Debug

This section explains how to run the Vio example on the Corstone SSE-310 FVP model. First, download and install
the SSE-310 FVP from the link provided in the Prerequisites section.

The VIO example might not work with newer Python versions. To run the example use version
Python3.9.x.

To debug the example inside the IAR Embedded Workbench software, follow the steps below.

Download arm_vio.py, like the following:

PS > wget https://github.com/ARM-software/AVH/raw/main/interface/python/arm vio.py -OutFile arm vio.py
Then uncomment the #verbosity = logging.DEBUG line in it.

Set environmental variables:
PS > $env:PYTHONHOME = 'C:/Users/<user>/AppData/Local/Programs/Python/Python39’

Start up the FVP with a CADI server:
<path to fvp>/FVP Corstone SSE-310 Ethos-U65.exe -S -C mps3 board.v path=<path to arm vio.py folder>

Configure the debugger inside IAR:
Open the project Options, by clicking on the root file in the Workspace and then selecting it from the Project menu
item. (Project > Options)
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Select the Debugger in the Category list and select CADI as Driver on the Setup tab.

QOptions for node “Blinky”

Categorny:

Factory Settings
General Options

Static Analysis

Runtime Checking
C/C++ Compiler Setup Pownload Images Multicore Authentication Extra Options Plugins
Assembler
Output Converter Driver 8 Run to
Linker

B — Setup mecos

TR | - use maco
w

CADI
CMSIS DAP

Figure 14: IAR EW: Selecting Debugger

You can select the desired CADI server in the CADI Category if there are more than one you wish
to use. Otherwise, it can be left empty.

To run the debugger click on the "Download and Debug" button. The application will be automatically loaded to the
model by the debugger.

8.4 Run - Terminal

1. Download arm_vio.py, like the following:

PS > wget https://github.com/ARM-software/AVH/raw/main/interface/python/arm vio.py -OutFile arm vio.py
Then set verbosity = logging.DEBUG in it.

2. Set environmental variables to run the example:
PS > $env:PYTHONHOME = 'C:/Users/<user>/AppData/Local/Programs/Python/Python39’

3. Execute the Example with the following command:
PS > <path to fvp>/FVP Corstone SSE-310 Ethos-U65.exe <path to out>/Vio.out
-C mps3 board.v path=<path to arm vio.py folder>

The VIO example might not work with newer Python versions. To run the example use version
Python3.9.x.
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9 Attachments

9.1 Blinky example tree

Files/Examples/Blinky/

L ]Blinky
] aPI

Include

qﬁ led_port.h

Source

QE led_port.c

Y Abstract. txt

{5 Blinky.cproject.yml
™ Blinky.h

{5 Blinky.c

{5 main.c

™ Makefile

{5 Blinky.csolution.yml

{5 cdefault.yml

{5 vcpkg-configuration.json

Figure 15: Blinky examples folder structure

9.2 Vio example tree

Files/Examples/Vio/
{i]Vio

Abstract.txt
Vio.cproject.yml
main.c

{5 Makefile

{5 Vio.csolution.yml

{5 cdefault.yml

{5 vcpkg-configuration.json

Figure 16: VIO examples folder structure
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