Keil Logo

Frequent 'ÄL9564I' License errors when building with sCons

Next Thread | Thread List | Previous Thread Start a Thread | Settings

Details Message
Author
lukas hönnighausen
Posted
19-Jul-2019 15:53 GMT
Toolset
C166
New! Frequent 'ÄL9564I' License errors when building with sCons

Hello,

i just setup a build environment based on sCons using the Arm Compiler. Everything seems to work out fine, except i frequently get License server errors. The error says "License server machine is down or not responding". I implemented my build environment to retry the compilation once the error occurs but every try after the initial run fails as well.

The same error happens from the Keil Ide from time to time, but far less often and only one time in a row.

I have to restart the whole build process to get rid of the error. Especially if i rebuild with the option '--clean', it seems to lower the chance of the error happening again.

Is there anything hidden i need to know about using xc16 compiler with external build environments? Is there some secret timing between compilating and linking that i miss or fall short off?

Any ideas?

Thanks in advance.

Next Thread | Thread List | Previous Thread Start a Thread | Settings

  Arm logo
Important information

This site uses cookies to store information on your computer. By continuing to use our site, you consent to our cookies.

Change Settings

Privacy Policy Update

Arm’s Privacy Policy has been updated. By continuing to use our site, you consent to Arm’s Privacy Policy. Please review our Privacy Policy to learn more about our collection, use and transfers
of your data.