Keil Logo

SWD communication failure.

Next Thread | Thread List | Previous Thread Start a Thread | Settings

Details Message
Read-Only
Author
Ashutosh Panwalkar
Posted
25-Jun-2018 07:49 GMT
Toolset
ARM
New! SWD communication failure.

Hi,

I am trying to program Nuvoton M058LBN using ULINK2.
But every time when I download code to flash memory it is showing me "SWD communication failure".

Can anybody help me with this issue?

Read-Only
Author
Westonsupermare Pier
Posted
25-Jun-2018 21:34 GMT
Toolset
ARM
New! Can anybody help me with this issue?

You're in the best position to actually fix the connectivity issue.

You could try options to "connect under reset", if there is evidence it is connecting at all.

Perhaps review and explain the connection as you have wired it, and whether the board/chip is otherwise functional or not.

Read-Only
Author
Andrew Neil
Posted
25-Jun-2018 22:57 GMT
Toolset
ARM
New! RE: when I download code to flash memory it is showing me "SWD communication failure".

Be more specific as to when, exactly, that occurs.

Is it before the download starts?

Is during the download?

Is it after the download, during verification?

etc, etc, ...

Is it a manufacturer's dev board, or your own design?

Has it ever worked?

etc, etc, ...

Next Thread | Thread List | Previous Thread Start a Thread | Settings

  Arm logo
Important information

This site uses cookies to store information on your computer. By continuing to use our site, you consent to our cookies.

Change Settings

Privacy Policy Update

Arm’s Privacy Policy has been updated. By continuing to use our site, you consent to Arm’s Privacy Policy. Please review our Privacy Policy to learn more about our collection, use and transfers
of your data.