Keil Logo

Trace not updating Event Viewer in Keil Uvision 5.15

Next Thread | Thread List | Previous Thread Start a Thread | Settings

Details Message
Read-Only
Author
Jeremy Neuman
Posted
22-Sep-2015 20:22 GMT
Toolset
ARM
New! Trace not updating Event Viewer in Keil Uvision 5.15

Prior to updating from Keil Version 4.72a to Keil Version 5.15, the Event Viewer, System and Thread Viewer, Memory and Watch Windows used to update in real time while the debugger was running with the Serial Wire Trace using the ULINK Pro. I still get the system notification Trace:Running... and when stopping the code execution the system view windows above will update to the last state, however they will not update real time, nor will the elapsed time (t0) update real time as it used to.

I left 4.72a installed, and now using this IDE, it also will not run in debug mode real time.

I've changed none of the project settings... only did the upgrade.

I found this functionality extremely useful and would like to get it back. Does anyone have any ideas what may have caused this change or where I can look.

Thanks

Read-Only
Author
Westonsupermare Pier
Posted
22-Sep-2015 21:22 GMT
Toolset
ARM
New! RE: Trace not updating Event Viewer in Keil Uvision 5.15

Do the release notes indicate a firmware update to the uLink Pro?

Read-Only
Author
Jeremy Neuman
Posted
23-Sep-2015 14:01 GMT
Toolset
ARM
New! RE: Trace not updating Event Viewer in Keil Uvision 5.15

From the release notes, it looks like the driver for the ULINK was changed at the 5.00 BETA3 release. I still have the previous installation 4.72a, so I reverted to that driver. The driver date did indeed change with the revert, however the functionality is still broken... no real-time updates of event viewer. One would think since both the 5.15 and 4.72 IDE's exhibit this problem it would be related to that common component, but it appears to be something else.

Any other ideas? Anyone else experiencing this? BTW - I'm executing from RAM instead of Flash, but this is not something that had changed when I upgraded the tools.

Thanks

Read-Only
Author
Per Westermark
Posted
23-Sep-2015 14:46 GMT
Toolset
ARM
New! RE: Trace not updating Event Viewer in Keil Uvision 5.15

Why not bring in Keil support on this issue, and then post back the outcome?

Read-Only
Author
Niclas R.
Posted
23-Sep-2015 16:01 GMT
Toolset
ARM
New! RE: Trace not updating Event Viewer in Keil Uvision 5.15

Hi Jeremy,

when you are in Debug-mode have a look under the "View"-Tab...is the option "Periodic Window Update" checked?

Regards, Niclas

Read-Only
Author
Jeremy Neuman
Posted
23-Sep-2015 16:06 GMT
Toolset
ARM
New! RE: Trace not updating Event Viewer in Keil Uvision 5.15

This was it... submitted a case to Keil and they provided that solution as well.

Thanks for your help!

Jeremy

Read-Only
Author
Julien MÊME
Posted
12-Sep-2017 16:58 GMT
Toolset
ARM
New! RE: Trace not updating Event Viewer in Keil Uvision 5.15

Is your issue solved?
Because I have the same problem.

ULink Pro and ULink 2
uVision V5.22.0.0
LPC4337 with CM4+CM0
Debug with SWO (so CM4 only)

Menu "View/Periodic Window Update" => Checked ;

Next Thread | Thread List | Previous Thread Start a Thread | Settings

  Arm logo
Important information

This site uses cookies to store information on your computer. By continuing to use our site, you consent to our cookies.

Change Settings

Privacy Policy Update

Arm’s Privacy Policy has been updated. By continuing to use our site, you consent to Arm’s Privacy Policy. Please review our Privacy Policy to learn more about our collection, use and transfers
of your data.