Keil Logo

new project in keil using stm32f10x

Next Thread | Thread List | Previous Thread Start a Thread | Settings

Details Message
Read-Only
Author
mahdiyeh ghazi
Posted
20-Apr-2011 12:51 GMT
Toolset
ARM
New! new project in keil using stm32f10x

hello, I'm trying to get familiar with keil, I run one of the example files on this soft to blink a led using stm32f10x and everything was ok but when I want to create a new project I get this error:

Empty.axf: Error: L6218E: Undefined symbol SystemInit (referred from startup_stm32f10x_md_vl.o).

I get this error even if I dont write any code in main, I also added stm32f10xr.lib to my project but it didn't solve the problem,

does anybody know what the problem is?
thanks in advance :)

Read-Only
Author
Martin Günther
Posted
21-Apr-2011 07:17 GMT
Toolset
ARM
New! RE: new project in keil using stm32f10x

Hello mahdiyeh ghazi,

you must add file system_stm32f10x.c to your project. Copy this file form folder .\Keil\ARM\Startup\ST\STM32F10x to your project folder.

According CMSIS V2.0 this file is used to set the core clock.

Best Regards,
Martin Guenther

Read-Only
Author
xdrone tek
Posted
2-Oct-2011 07:48 GMT
Toolset
ARM
New! RE: new project in keil using stm32f10x

I got the same error:

test2.axf: Error: L6218E: Undefined symbol SystemInit (referred from startup_stm32f10x_md_vl.o).

and nothing seemed to work, copying stuff won't help.
It was running earlier though, other projects still run but mine won't.

Please help.

Next Thread | Thread List | Previous Thread Start a Thread | Settings

  Arm logo
Important information

This site uses cookies to store information on your computer. By continuing to use our site, you consent to our cookies.

Change Settings

Privacy Policy Update

Arm’s Privacy Policy has been updated. By continuing to use our site, you consent to Arm’s Privacy Policy. Please review our Privacy Policy to learn more about our collection, use and transfers
of your data.