Keil Logo

uLink error: "Too many JTAG devices in chain"

Next Thread | Thread List | Previous Thread Start a Thread | Settings

Details Message
Read-Only
Author
Mathias Kreider
Posted
3-Nov-2009 19:53 GMT
Toolset
ARM
New! uLink error: "Too many JTAG devices in chain"

Hi folks

I tried to download a binary file to an STR911FAM44X6
with the demo version of uVision4.
Unfortunately, it says "Too many JTAG devices in chain".
I do not understand that message, since there is only the one ARM9 chip on the board and its exclusively connected to the uLink. Does anyone know what uVision is trying to tell me?

Any help would be much appreciated

Cheers - Mathias

Read-Only
Author
Lillian Xu
Posted
3-Nov-2009 20:30 GMT
Toolset
ARM
New! RE: uLink error: "Too many JTAG devices in chain"

Try to do it based on this link http://www.keil.com/support/docs/3215.htm

Read-Only
Author
Mathias Kreider
Posted
3-Nov-2009 21:03 GMT
Toolset
ARM
New! RE: uLink error: "Too many JTAG devices in chain"

Hi Lilian, thx for your reply

Well, the chip is brand new and has been freshly soldered to the board. I don't see how there could be
any code on it, but I tried the suggested solution anyway.

I tried it out about 20 times, but I either get the
"Too many devices in JTAG chain" error or if i pull nRST to GND for longer, I get "JTAG communication failure" :(

Any other ideas what this could be?

Cheers - Matze

Next Thread | Thread List | Previous Thread Start a Thread | Settings

  Arm logo
Important information

This site uses cookies to store information on your computer. By continuing to use our site, you consent to our cookies.

Change Settings

Privacy Policy Update

Arm’s Privacy Policy has been updated. By continuing to use our site, you consent to Arm’s Privacy Policy. Please review our Privacy Policy to learn more about our collection, use and transfers
of your data.