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This tutorial will instruct you on how to use the Keil Microsoft Windows based software development tools with the Intel 8x930 based evaluation board.  This is the Rev B board with 4 USB ports.  The earlier version had 3 USB ports.   This board comes with a N80930AD4 USB microcontroller.  A daughter board is available for the 930 HUB device.  It contains a N80930HF0 device.  The Intel Evaluation board can then be used as a hub device.  This paper is known as Application Note # 111.

For more information you may visit these Web sites:



http://developer.intel.com/design/usb/

http://www.keil.com/usb

http://www.usb.com

Check http://www.keil.com/~market for up to date information.  This is the Web page for the Keil USA Marketing Group.



Keil is providing USB information of interest to developers.  This includes:

sample enumeration code

instructions on how to compile code using the Keil compiler and burn it into an Eprom that will run on the Intel USB board stand-alone - Application Note # 112 - www.keil.com/~market/112.zip

C code sample programs to demonstrate other functions of dScope such as the Performance Analyzer

information on interfacing the Keil tool chain to a customer hardware board.

The Keil monitor is available for the Intel USB board - www.keil.com/~market/mon251.zip

Keil has a USB specific CD-ROM that is available for free.  Call for more information.
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Notes:

This document is continually being updated.  For the latest version check www.keil.com/appnotes or Email rboys@keil.com or phone (800) 348-8051.  Check the Keil Marketing Web site www.keil.com/~market for any late developments.

Every effort has been made to ensure that the information contained here actually works.  �Please report any errors or omissions to the author at the addresses listed above.

�INTRODUCTION



The 8x930 USB microcontroller uses the Intel MCS(251 core.  The Keil C251 compiler comes with additional header and include files to accommodate the 8x930 USB peripherals.  The compiler and assembler generate native 251 code.  They are written expressly for the 251 family.  Binary and Source modes are supported.  They generate code in either source or binary mode and paged or non-paged mode.  All facilities of the 251 and 930 microcontrollers are accessible.



The Keil tool chain consists of the following executables:



(Vision		uvw251e.exe

C Compiler	C251.exe

Assembler	A251.exe

Linker		L251.exe

dScope		dsw51.exe



These files are located in the c:\c251eval\bin directory.  They are DOS programs.  It does not make much sense to design these as Windows applications.  Access to these programs from Windows is accomplished with (Vision.  The entire tool set can be run from (Vision or directly from DOS.



(Vision IDE

(Vision is a Windows based front end for the C Compiler and Assembler.  It was developed in the USA as were the printed manual set.  Compiler, Assembler and Linker options are set with simple mouse clicks. (Vision runs on Windows 3.1, 95 and NT.  This Integrated Development Environment (IDE) has been expressly designed with the user in mind.  A full function editor is included.  All IDE functions are intuitive via pull down menus with prompted selections.  An extensive Help utility is included.  External executables can be run from within (Vision.  This includes emulator software.



C251 C Compiler for the 251, 151, 8x930 [USB]

The C251 ANSI compiler with the A251 assembler are designed specifically for the Intel and Temic 251 microcontroller family, including the 8x930 USB.  The C251 is 100% compatible with existing 8051 programs.  Extensions provide access to all 251 hardware components.  Sample USB/251 code is available: www.keil.com/usb.  C251 supports code banking, source and binary modes.  The compiler can be run in either DOS mode or called from the Windows based front end (Vision.



A251 Macro Assembler

This Macro Assembler is included with each Compiler package or is available separately.  All utilities needed to complete your project are included for all members of the 251 family.  This Assemblers is DOS based or can be run from (Vision which is included with every Assembler and Compiler package.

�L251 Linker

The L251 Linker/Locator is used to join relocatable object modules and library files together.  The object files were created with the C251 compiler or the A251 Assembler and the library files are provided by Keil.  This process results in absolute object modules.  The L251 is DOS based and can be run from DOS or through Windows using (Vision.  A MAP file is also produced giving details of the memory structure.  This object file may be specified to contain debugging information as required by simulators, debuggers and emulators.  The L251 can overlay important internal RAM for variables to greatly increase the speed of processing.



dScope Simulator

dScope is a software simulator.  Your code can be debugged either in software on your PC or in your target hardware.  When operated in conjunction with the Keil monitor installed in your target hardware, dScope becomes tScope.  You have the ability to run/halt, set breakpoints, examine/change memory, view the stack, view/set peripheral information and apply virtual external signals.  dScope has a Performance Analysis feature to ensure your code runs efficiently.  dScope has a disassembler/assembler allowing you to make changes in your code without recompiling.



The evaluation version of the Keil tool set is restricted to a 2K code size and the code must be located at 0x4000.  Useful object code is produced.  Other than these restrictions, the tool set works exactly as the full version does.  This allows you to fully evaluate the features and power of Keil products.  The full version has no restrictions and is fully ANSI compliant.



ABOUT THIS TUTORIAL



This tutorial consists of several sessions illustrating the features of the Keil Tool Set.  The assembly language program shown above will be modified and run using various features of the Keil C251 Tool Set.  The focus is on using Keil’s (Vision integrated development environment.  It explains how to create and build a new project using a source code example provided in this tutorial.

The following steps below show you how to configure the tools, assemble and link the code, and invoke the debugger, dScope.  Before you begin this tutorial, you need the Keil software development tools.  To get them do one of the following:

Locate the evaluation version of the Keil software development tools that shipped with the USB 8x930 peripheral development kit.

Download the latest version of the software from the Keil web site (www.keil.com).

Purchase a complete package from Keil Software.



STARTING THE TUTORIAL

Installing the Keil Software

Install the Keil Software development tools by completing the following steps:

Insert your installation diskette number 1 in the A: drive.

In the Program Manager select File/Run…     (for Windows 95 select Start/Run…)

Type A:\Setup at the Command Line Prompt.

Press OK.

Follow the on-screen prompts.

 After you install the Keil development tools to Windows 3.11, a Keil program group or icons appears on your desktop.  (the Windows 95 version is shown in Figure 1).  Recall dScope is the Keil Simulator and (Vision is the Keil Windows based user interface (or IDE = Integrated Development Environment).
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FIGURE 1 



For Windows 95 you must install the two icons manually as follows.  If the two icons are visible in a small window drag them onto the desktop.  If they are not visible, follow these instructions:



right mouse click while in the Desktop

select New/Shortcut

The executable file you want to enter as the Command Line is c:\c251eval\bin\uvw251e.exe

The suggested name is (Vision.

Repeat this process for c:\c251eval\bin\dsw51.exe and name it dScope.



Starting the Software:



Double-click on the (Vision icon to start the user interface.  The compiler, assembler, linker and dScope will be called from within (Vision in this tutorial.  After you invoke (Vision, the window shown in Figure 2 appears.  From this window, you can create projects, edit files, configure the tool, assemble, link, and invoke the debugger.

The first time (Vision is run after installation a window may appear notifying you that a tool set must be selected.  The tool set specifies whether version 1 or 2 of the Keil 251 compiler is used.  Select Version 2 when prompted by clicking on Keil 80251 C Compiler V2.x (DLL 1.21).  Version 1 is the Keil 8051 based compiler adapted for the 251.  Version 2 is built especially for the 251and compiles more compact code among other benefits.  The Extended Bit Architecture and all advanced 251 instructions are supported.  You can change this setting at any time by opening the File menu and selecting Tool Set.  Note that (Vision does not return the name of the correct setting in this window but will properly set it.
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FIGURE 2



CREATING A NEW PROJECT



Open the Project menu and choose New Project.  The window shown in Figure 3a appears except that *.prj shows under File name instead of newp.prj.

Enter the name of the project you are creating.  For this tutorial, enter the name newp.prj and press OK.  Newp.prj will be entered under File name: as shown in Figure 3a.  Figure 3b will open up.

�

FIGURE 3a
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FIGURE 3b

This window is used to add various files to your project.  These include ASCII files, C and assembly source and macros.  The list is quite extensive and is found in the Translator window if any files are present in the project.  Note this window is blanked out at this time.  This window is accessible at any time by selecting Project/Edit Project and you may easily edit your file list.  Note that any assembler files must be last in this list.  If they are not, changes made to them will not be reflected in the final object file.

When creating a new project in this manner no source files are yet available.  Therefore, select save to close this window.  Your project newp.prj will be active.  Click on Project and confirm newp.prj is visible at the bottom of this pull down menu.



CREATING A NEW SOURCE CODE FILE



Open the File menu and choose New to go to the integrated editor.  If you already have the source listing, choose Load instead.

An editor window appears in the (Vision window.  Use the editor to type in the example program in Figure 5.  The following program uses a number of MOV instructions to port-1 of the 8x930 device and it sets up Timer-1 to cause an interrupt after it overflows.  This program is used in the remainder of the tutorial.  You may also get this file from the Web:  www.keil.com/usb.zip.

After you finish typing the code, open the File menu and choose Save.  The window shown in Figure 4 appears.

Select the directory where you saved the project.  This tutorial uses the directory: c:\c251eval\bin

Enter the name of the file you are saving and press OK.  This tutorial uses the name: timer1.asm.

At this point you have created a project called newp.prj and an assembly source file called timer1.asm.

The next step is to build your project.  This includes compiling (not done here), assembling, linking and locating and creating the hex file.
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Figure 4



�$include (reg930ax.inc)



start segment ECODE AT 04000H			;code area starts at 0x4000

	RSEG start					;relocatable segments

	jmp MAIN

T_ISR segment ECODE AT 0401BH			;timer interrupt service

;routine starts at 0x401b

	RSEG T_ISR

	JMP TIMER_ISR

MAIN1	segment ecode at 04100H

	RSEG MAIN1



MAIN:						;Main program starts HERE !

MOV TMOD,#00010000B			;sets Timer mode control register

MOV P1,#00000000B				;this section lights the leds

MOV P1,#00000011B				;

MOV P1,#00001111B				;

MOV P1,#00011111B				;

setb IE0.3					;enable timer 1 (T1) interrupts

SETB TR1					;set run control bit and turn T1 on

STAY: JMP STAY				;stay here forever



TIMER_ISR:					;timer interrupt service routine

clr IE0.3					;disable timer 1 (T1) interrupts



MOV P1,#00010000B				;turns leds on one by one

MOV P1,#00011000B				;

MOV P1,#00011100B				;

MOV P1,#00011110B				;

MOV P1,#00011110B				;

MOV P1,#00011111B				;

stay1: JMP stay1				;stay here forever and a day

setb ie0.3					;enable timer 1 (T1) interrupts

RETI						;return to main program

END





Figure 5. Example Program

�BUILDING THE PROJECT

Open the Options menu and choose Make.

Click on Extensions. The window shown in Figure 6 appears.

Replace A51 in the A251 Assembler window with asm and click OK.  This makes the file timer1.asm a legal filename.  You could also change timer1.asm to timer1.a51.
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FIGURE 6



Open the Project menu and choose Edit Project.  The window shown in Figure 7 appears.  This is where you add various files to your project.  Note there are no files in the project yet.�
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�FIGURE 7











Choose Add.  The window shown in Figure 8 appears.  This is where you add the files to your project.

����FIGURE 8

Make sure you are in the correct directory: c:\c251eval\bin., change *.c to *.asm in File Name.

Select the file: timer1.asm and press Enter

Choose Add then Close.  TIMER1.ASM will be listed in the Source Files window.

Click on Always Build so this is activated.  Include in Link/Lib should also be active.

Choose Save.



CONFIGURING THE MAKE UTILITY, ASSEMBLER, AND LINKER



Keil Software has a Make utility that can compile and link C and/or assembly coded files.  It also has other configuration and default setting features.  Before using the make utility, configure the make options.  Make the changes as indicated and leave all other options set to their default values.  (Vision allows you to set various options with mouse clicks and these are all saved in your project file.



Configure the Make utility.

Open the Options menu and choose Make.

Configure the options in the window as shown in Figure 9 and press OK.
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FIGURE 9 

Configure the Assembler.

Open the Options menu and choose A251 Assembler.

Configure the options in the window under Object as shown in Figure 10 and press OK.
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FIGURE 10

Configure the Linker.

 Open the Options menu and choose L251 Linker and choose the Linking tab.

 Configure the options in the window as shown in Figure 11a and press OK.

Choose the Misc. tab - Figure 11b opens up.

In Class 1 enter	ecode(004000h-00ffffh).
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FIGURE 11a
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FIGURE 11b

Additional Notes:

The include file reg930ax.inc must be obtained from Keil Software and installed in the directory c:\c251eval\asm to get the maximum utility from the compiler.  This file is obtained from the Web at www.keil.com\usb.zip.  You may call 800-348-8051 or Email rboys@keil.com if you do not have Web access.  This file is available free of charge.  This .zip file includes the source file in Figure 4 and a sample project file new.prj.

You must have a directory called c:\tmp on your hard drive.  This is created by Windows during its installation and is used by Keil for storing temporary files.



ASSEMBLING THE CODE AND CREATING AN EXECUTABLE FILE



Once you have configured the tool, you are ready to run the assembler and linker using the Make utility.



Click on the Make icon (it has three arrows pointing downwards) or open Options and select Make.

If the program specified (timer1.asm) has any errors, a list of errors appears on the screen.



If there are no errors, the code  is assembled and linked and the executable code is ready to be downloaded to the board.  Continue to the next section.

If a list of errors appears, use the editor to correct the error(s) in the source code and save the file.  Then, repeat this section: beginning at step 1.

�DOWNLOADING THE CODE TO THE 8X930 EVALUATION BOARD



You are now ready to run the dScope debugger to download code to the evaluation board.

Connect the serial cable from a COM port on your PC to the UART port on the Intel USB board.  The blue cable provided by Intel works fine.  Supply regulated 5 volts to P9 on the board.  Please carefully apply the correct polarity.

With the serial cable not connected and the power applied to the board; the LEDs will indicate a self test and the even numbers of P1 plus p1.7 will remain illuminated at the conclusion.  Pressing the reset button will repeat the self test.  The green LED CR1 always remains lit as long as reset is not asserted.

With the serial cable hooked up; all the LEDs remain illuminated as the board is held in the reset condition by the serial port.  Use the default board jumper locations.

Click on the debugger icon on the (Vision toolbar.  This icon is a “d” seen through a magnifying glass and is yellow and blue in colour.  This is the same icon installed for dScope in your desktop area.  If you leave the mouse pointer on an icon for a few seconds, the word “debug” will appear.  A window similar to that shown in Figure 12 is displayed.  You may want to move and resize the windows.  The window marked “Module: <none>” is the Debug window.  The Command window will be needed to enter commands.
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FIGURE 12

�INTERFACE SETUP



Before you can load the executable file to the debugging environment and to the evaluation board, make sure you have the correct driver and interface.  dScope is a software debugger and simulator.  tScope is the debugger connected to a hardware system.  Programs are run on the target hardware rather than in the virtual microcontroller in your PC.  The Keil debugger tScope will communicate with the Intel RISM monitor contained in the EPROM on the USB board.

The upper left hand corner of Figure 12 shows that dScope is active in this case.  This will change to tScope if the appropriate dll (i.e. rism930.dll) is chosen. If you select 82930.dll, you will get dScope.  Your simulation will not be run on the Intel USB board but in your PC as already stated.



To establish communication with the evaluation board, choose the correct driver using the pulldown list on the left portion of the debugger toolbar.  In this example, rism930.dll is chosen.

rism930.dll:  When the serial link is connected and the rism930.dll is selected for the first time, the leds will blink.  The reset button in the tScope Toolbox window will also cause the lights to blink.  If you get this far, things are working properly.  tScope should be displayed in the upper left hand corner.

This will happen only if communication is established.  If the wrong COM port or speed is selected a series of communication I/O timeouts will be indicated in the Command window.  If this happens; follow the instructions under Communications Setup.



COMMUNICATIONS SETUP



You need to follow these instructions if proper communication was not established.  After a series of attempts dScope will error out as indicated in the command window and the icon bar will change to contain a Peripherals menu.

Click on this and select Configuration.  The Configuration window will appear.  Select the appropriate COM port for your system.  The speed must be 19200 for the external UART and the Serial Break must not be enabled for this exercise.  When you select Apply - the LEDs will blink if the settings are correct.

For the Internal serial port:  choose a baud rate of 9600.  We recommend using the UART port however.  After you set the COM port and baud rate correctly, click on Close.



LOADING THE EXECUTABLE FILE TO THE DEBUGGER ENVIRONMENT



Open the File menu and choose Load Object.

In the Window provided, select the file: newp.  The file is downloaded to the board and the debugger.  You may not see the code on your screen, because the example program starts at 004000H (required by the board design), but the debugger displays code locations at FF0000H.

To see the code, enter the following command in the Command window:

$ = 0x4000		This Command sets the Program Counter ($) to hex 4000.

To see the Command window if not already visible, select View/Command Window.  To see the source code, select the Debug window in the same fashion.

Press enter.

You should see the source in the Debug window as in Figure 13 depending on how you have set your windows.  You can single step using the step-into icon.  You are now ready to use the dScope window (really tScope) to step through code, set breakpoints, and issue the Go command to start program execution.  You can examine special function registers, memory locations, and register values, etc.
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FIGURE 13



SAMPLE SESSIONS



Single Stepping

dScope uses “Step Into” to single step one instruction at a time.  “Step Into” is also used to enter a function in the same fashion.

“Step Over” means to skip over a function that you are not interested in.  

“Step Out” is used to exit a function you are currently in. “Step Out” is very useful if you find yourself in a function you are not interested in and need to return quickly to your intended function.

When you are at the point in Figure 13, you can click on Step Into! And as you step through each instruction the LEDs will light up as assigned by the MOV instructions.  You will not be able to progress past the SJMP to itself at line #21.

If you open the Peripherals option and select I/O Ports and repeat this session’s instructions, the status of the LEDs will be reflected in this window.  This is most useful for simulating hardware that does not exist yet.

Breakpoints

Reset using the RESET box on the Toolbox or click on the button next to the Help “?”.

This button has a red pointer coming from it.  The lights on the board should change.

Click in the Command window and press the up arrow key to get the history of keys typed.  “$=0x4000” will show.  Press the Return key to activate this command.

Click on “Step Into”  to return to the Main program.

Click on a memory location such as 4109 and a colored bar appears marking this position.

You could click on Go Til Curs! To reach this point or you could double-click and a breakpoint is set.  Set a breakpoint here with the double click.  The [BR0] indicates the first breakpoint.

Click on GO and the program will run and stop at the breakpoint.  - 3 LEDs will be on.

Double click on the breakpoint to remove it. 



In Line Assembler

Click on Reset and set the PC to MAIN by entering $=0x4100 in the Command window.  Press Enter.  This avoids using the Step Into! Key to reach Main.

Open the Commands option and click on Inline Assembler or if Show Dialogbar is active, click on the Assemble button in the Debug window.

The Inline Assembler windows opens as in Figure 14.

Double click on line # 21 - 0x004113 sjmp …….   - this is the endless loop.

The entire instruction of line #21 appears in the box under Enter MCS-251 instruction.

Block all of line #21 with the mouse and type in the instruction nop.

Press Enter or click on the Assemble button and notice the sjmp has been replaced with a NOP.

Click on Close.

So !  You can now single step through the bottom half of the sample program with the “Step Into” button until you reach the second sjmp.
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Figure 14

�CONCLUSION



What else is there ?



Plenty…  

Open the Command option in the Debug window and notice you can select High Level Language, assembler or both (mixed) to be displayed and the trace.  Note the trace only works for software simulation - tScope is unable to determine the actual bus values in your hardware.

Open View and note the many windows you can open such as Watchpoints, Register, Performance Analysis and Code Coverage.

Open Peripherals and you can see windows illustrating values of I/O Ports, Timers and counters.

Open the Setup window and you can set many options such as the Performance Analyzer, Register sets, breakpoints and Watchpoints.

On line Help is also available. 

An Application Note giving instructions on how to replace the RISM Eprom in the Intel evaluation board with your own code produced with Keil software.  Application Note 112 from www.keil.com



What is next ?



Plenty…

More sessions using C code will be prepared.  More dScope features will be explored such as the Performance Analyzer, Watchpoints and Memory windows.

These will be available sometime in July and August.  Check www.keil.com/~market for further details.



For additional information on Keil software development tools, visit the Keil web site at : www.Keil.com.  Check the Keil Marketing Group Web page at www.keil.com/~market.



For more information regarding the entire Keil tool chain…..see the Help file Evalkit.hlp located in the root of the Keil CD-ROM available free from Keil.



Any problems or questions ?  Call us.  We are here to help you with your USB project.



Robert Boys, BBA, MIS, CMA

Dallas, Texas

July 15, 1997

�Intel Support from Keil Software Inc.  Dallas, Texas

Keil Software develops, manufactures, and distributes embedded software development tools for the 8051, 251, and USB microcontroller families.  Tools include C compilers, Assemblers, Real-time Executives, Debuggers and Simulators, Integrated Environments, and Evaluation Boards.  Keil has a training facility in Dallas for 8051 and USB products.  Keil provides distribution, product development, and technical support from its office in Dallas, Texas.

Keil’s web site [www.keil.com] provides the latest information about our development tools, demo programs, software updates, application notes, example programs, and links to other sources of information.

C51 C Compiler for the entire 8051 family and the Intel MCS(151

The C51 is a full ANSI C compiler with assembler.  (Vision is the Windows User Interface that drives the optimizing C51.  The Compiler, Assembler and Linker options are point and click.  (Vision and the manuals are written in the USA and extensive on-line help is included.  Free technical support from Dallas via a 1-800 line is included for one year.

C251 C Compiler for the 251 and the 8x930 [USB]

The C251 ANSI compiler with the A251 assembler are designed specifically for the Intel and Temic 251 microcontroller family, including the 8x930 USB.  C251 is 100% compatible with existing 8051 programs.  Extensions provide access to all 251 hardware components.  Sample USB/251 code is available: www.keil.com/usb.  C251 supports code banking,  source and binary modes.  Keil has a free tutorial available for the new Intel 4 port USB evaluation module and the C251.

A51, A251:  Macro Assemblers for all Keil supported microcontrollers

These three Macro Assemblers are included with their respective Compiler package or are available separately.  All utilities needed to complete your project are included for all members of the assembler’s family.  These Assemblers are DOS based or can be run from (Vision which is included with every Assembler and Compiler package.

(Vision Integrated Development Environment - Windows based User Interface.

(Vision is a USA developed Windows-based front end for all Keil Compilers and Assemblers. It includes an editor, project manager, and make facility.  Compiler, assembler, and linker options are set by pointing and clicking on prompted selections.  Program Manager conveniently accesses your  files, and 3rd party executables and also calls the Keil Simulator dScope easing the transition from utility to utility.  Works with Windows 3.11, 95 and NT.

dScope-Debugger and Simulator for the 8051, 251 and 930.  Windows or DOS based.

dScope is a source-level debugger that lets you debug programs created by Keil compilers.  dScope simulates your program either in stand-alone mode or in your target using the monitor.  External hardware, signals, and interrupts can be simulated.  Viewable windows include View Program from I/O, Trace, Stack, Watch and CPU registers plus more.

TR51/FR51/FR251 Full-Function RTOS for the entire 8051, 251 and 8x930 families

The RTX51 and RTX251 are a multitasking Real-time Operating Systems for the entire 8051, 251 and 8x930 families.  This powerful tool lets you manage multiple tasks on a single CPU. The RTX51 Full includes CAN libraries.  The RTX51 Tiny is a subset of the RTX51 Full.  Functions include interrupt and memory management, clock, and semaphores.  Royalty-free.

CAN Library

The RTX51 Full RTOS supports CAN controllers with the included libraries.  The CAN libraries are sold with the RTOS.  The CAN interface is becoming popular for automotive and industrial markets. 11 and 29 bit identifiers are supported.  Keil 8051 C compilers  interface with the RTOS and CAN libraries.  Keil supports all CAN microcontrollers based on the Siemens C515C the Philips 592 and the Intel 526 and 527.





Upgrades

Free updates for Keil compilers are available from the Web to registered users.  Special upgrade prices are available for selected Franklin and Archimedes compilers.  Call Keil for details on how to save money using this special program.



Keil Software						phone	(800) 348-8051

16990 Dallas Parkway, Suite 120			phone	(972) 735-8052

Dallas, Texas  75248-1903				fax	(972) 735-8055

							Email	sales@keil.com

							Web	www.keil.com
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